Updating my plugins throws error relative to Vanilla version

  • I have a problem with nodebb-vanilla theme that is not satisfying its siblings depencies whenever I update or install a new plugin I got this error :

    npm ERR! peerinvalid The package nodebb-theme-vanilla does not satisfy its siblings' peerDependencies requirements!
    npm ERR! peerinvalid Peer nodebb-theme-lavender@0.1.12 wants nodebb-theme-vanilla@~0.1.0
    npm ERR! peerinvalid Peer nodebb-theme-quickstart@0.0.0 wants nodebb-theme-vanilla@~0.0.1

    I've tried to update both lavender and vanilla but that doesn't work.
    Also I'm unable to remove nodebb-theme-quickstart as the package is not in node_modules. It seems to be installed globaly but I don't know why.

  • Seeing the same issue on my new 0.5.3 install as well.

  • Can you try running npm rm nodebb-theme-quickstart in your NodeBB folder. If that fails, try npm i nodebb-theme-quickstart@latest

  • Admin

    To remove a globally installed package:

    npm unl -g nodebb-theme-quickstart

  • Same issue here with Vanilla and Lavender

  • On 0.5.7 and the issue continues. The quickstart removal doesn't help as it is not installed.

  • If you remove Vanilla itself, it seems to be okay.

    npm rm nodebb-theme-vanilla


| |