npm install error messages

General Discussion
  • Any concerns? See the following message during npm install

    npm WARN engine [email protected]: wanted: {"node":"0.8.x"} (current: {"node":"v0.10.25","npm":"1.3.10"})
    npm WARN engine [email protected]: wanted: {"node":"0.8.x"} (current: {"node":"v0.10.25","npm":"1.3.10"})
    npm WARN engine [email protected]: wanted: {"node":"0.8.x"} (current: {"node":"v0.10.25","npm":"1.3.10"})
    npm WARN engine [email protected]: wanted: {"node":"0.8.x"} (current: {"node":"v0.10.25","npm":"1.3.10"})
    npm WARN engine [email protected]: wanted: {"node":"0.8.x"} (current: {"node":"v0.10.25","npm":"1.3.10"})

    [email protected] install /root/nodebb/node_modules/reds/node_modules/redis/node_modules/hiredis
    node-gyp rebuild

    /bin/sh: 1: node: not found
    gyp: Call to 'node -e "require('nan')"' returned exit status 127. while trying to load binding.gyp
    gyp ERR! configure error
    gyp ERR! stack Error: gyp failed with exit code: 1
    gyp ERR! stack at ChildProcess.onCpExit (/usr/share/node-gyp/lib/configure.js:431:16)
    gyp ERR! stack at ChildProcess.EventEmitter.emit (events.js:98:17)
    gyp ERR! stack at Process.ChildProcess._handle.onexit (child_process.js:797:12)
    gyp ERR! System Linux 3.13.0-36-generic
    gyp ERR! command "nodejs" "/usr/bin/node-gyp" "rebuild"
    gyp ERR! cwd /root/nodebb/node_modules/reds/node_modules/redis/node_modules/hiredis
    gyp ERR! node -v v0.10.25
    gyp ERR! node-gyp -v v0.10.10
    gyp ERR! not ok
    npm WARN This failure might be due to the use of legacy binary "node"
    npm WARN For further explanations, please read

    npm WARN optional dep failed, continuing [email protected]

    npm WARN package.json [email protected] No repository field.

  • Are you running on Windows?

  • @julian

    Running ubuntu 14.04 64-bit. I even did another test run with clean install after apt-get update and upgrade.

  • Ah sorry, my bad 😄

    Try installing nodejs-legacy package. That will introduce the node executable to your PATH env.

    ... or just symlink node to nodejs.

  • Another note: If you have the nodejs package, you probably installed it from the repository. That means it may not be up to date. I always build it from source, since the repositories are usually a ways behind the development.

  • Agreed, although I just use the Ubuntu PPA. Une of the first commands I run on a new box is:

    # sudo add-apt-repository ppa:chris-lea/node.js-devel
    # apt-get update && apt-get install nodejs
  • @pitaj @julian

    Perhaps I'm not interpreting the error message correctly. Isn't it asking for earlier version of node? If so, what is calling for that and is that something that can be corrected on the nodebb side looking for an older version?

    Since my ubuntu setup has v0.10.25 and nodejs site shows v0.10.32 (don't think we need to constantly upgrade), I'm curious what the minimum is for nodebb 0.5.1

  • @peter Those warnings are just that, warnings. Those packages were created before there was a Node.js 0.10.x, although I'm sure they work just fine.

    As for the hiredis error, you can fix it by installing nodejs-legacy, but hiredis is not a required dependency. If it fails, redis just runs a little slower, but that's fine 😄

  • @julian your explanation eases my concerns. Would be nice to see none at all but at least we know it's not critical to the operation of nodebb for production. Thank you!!

Suggested Topics