Move a NodeBB forum


  • Plugin & Theme Dev

    Hello guys,
    I want to move my forum a dedicated computer,
    but the testing I made are not conclusive.

    Copying the Redis dump do not seems to work.
    It ask me for a db --upgrade or --no-check-schema

    Either one, the node app start, and I get an empty forum.

    What could I do about that?

    (Besides, after npm update, I usually get error from bcrypt not loading, solved by npm install brypt. Should I post an issue about that?)

    Thanks


  • Admin

    Hello @tedr56,

    Copying the RDB dump file should be sufficient to transplant a NodeBB from one server to another (assuming the configuration files are the same).

    Please be advised that the redis service must be stopped before the replacement dumpfile is copied to the final destination, otherwise redis will overwrite it with the current database (in memory) when it is stopped and restarted.


  • Plugin & Theme Dev

    Forgot to mention, it worked.

    Indeed, redis dump, config files and uploads are sufficient.

    I stopped the redis server before making the dump, and of course, before restore it.

    Thanks



  • I must be missing some steps.. I shut down the old server, copy the redid db file, same on DO, down and upload file.. but i'm missing all users, categories, etc.. so i know i f'd it up.. just reset the droplet since i went haywire on it haha.. restarting now the process 🙂



  • I must be missing some steps.. I shut down the old server, copy the redid db file, same on DO, down and upload file.. but i'm missing all users, categories, etc.. so i know i f'd it up.. just reset the droplet since i went haywire on it haha.. restarting now the process 🙂

    Okay detailing steps.. Any tips appreciated.

    1 - shut down redis and node
    2 - back up the empty dump file to be safe
    3 - copy backed up dump file to new server
    4 - turn redis and node back on

    Any specific commands or tricks, things to look for, etc??


  • Admin

    Yes, this is the correct sequence of steps.

    Note that there are some things that can go wrong. In my experience, I know that a redis 2.6 dataset cannot be loaded by redis 2.4.



  • Make sure redis is bleeding edge added to the list of pre-reqs 🙂


Log in to reply
 

Suggested Topics

| |