Upgrading issues from 0.4.x to 0.4.3 (latest as of Jul 26 @ 1:10pm)

  • Community Rep

    Hey guys, I just updated from somewhere in 0.4.x (it might have been very early in 0.4 since I upgraded to get the finder plugin to work with 0.4 in the first place), and now on 0.4.3, which I just pulled a few minutes ago. I did a ./nodebb upgrade and was greeted with this little tidbit:

    error: Unable to initialize Redis! Is Redis installed? Error :Cannot read property 'Store' of undefined
    

    ...but the dependencies are up to date.

    Anything major change in the DB schema?


  • Run nodebb setup again. It will install redis dependencies. (All your existing configs should be saved, so could be a case of spamming enter (unless you use a password on redis))

  • GNU/Linux Admin

    Yep, thanks @a_5mith, @BDHarrington7, there's an upgrade script that takes care of this, but it's only available for v0.5.0 😕

    But for your case, the ./nodebb setup workaround should fix it right up.

  • Community Rep

    Thanks, @a_5mith that got me running again!

Suggested Topics

| |