Your account has been locked temporarily



  • My admin account says all the time 'locked temporarily'. It's been like this for over 1 week. I used to have nodebb-spam-be-gone and it has cause me many problems such as immediately banning moderator accounts, or administrators which shouldn't be allowed, those are trusted members. I removed it and everything was fine for a bit until this. Is there a way to unlock all accounts?


  • Global Moderator

    @anooxy If you're using honeypot, it will only ban IP addresses that appear in that honeypot. So either your mods are spammers, or they're suffering from the effects of Dynamic IP addresses. Pinging @bentael as it's his plugin.


  • Admin

    @anooxy The only condition (that I am aware of) that would cause an account to be locked is repeated login attempts to an account. A quick way to reset the lockout (it should reset over time) is to look in your redis database for any keys that start with "lockout:" and delete them:

    redis-cli
    keys lockout:*



  • I get this when I try to login now:

    node_redis: no callback to send error: Error: ERR unknown command 'pexpire'
    Error: Error: ERR unknown command 'pexpire'
        at HiredisReplyParser.<anonymous> (/home/xxx/xxx/node_modules/redis/index.js:263:27)
        at HiredisReplyParser.EventEmitter.emit (events.js:95:17)
        at HiredisReplyParser.execute (/home/xxx/xxx/node_modules/redis/lib/parser/hiredis.js:41:18)
        at RedisClient.on_data (/home/xxx/xxx/node_modules/redis/index.js:488:27)
        at Socket.<anonymous> (/home/xxx/xxx/node_modules/redis/index.js:82:14)
        at Socket.EventEmitter.emit (events.js:95:17)
        at Socket.<anonymous> (_stream_readable.js:745:14)
        at Socket.EventEmitter.emit (events.js:92:17)
        at emitReadable_ (_stream_readable.js:407:10)
        at emitReadable (_stream_readable.js:403:5)

  • Admin

    Update redis to 2.6.0

    sudo apt-get install -y python-software-properties
    sudo add-apt-repository -y ppa:rwky/redis
    sudo apt-get update
    sudo apt-get install -y redis-server
    

    Wonder if we should do a check for redis version on startup here, I'm sure @a_5mith has gotten tired of posting the above over and over again 😛



  • @psychobunny I got no users now, did they rename the dump.rdb?


  • Global Moderator

    @psychobunny We need a reddit autobot, if it sees Error: ERR unknown command 'pexpire' , it creates a post immediately with the command to update redis. 😆


  • Admin

    @anooxy said:

    @psychobunny I got no users now, did they rename the dump.rdb?

    Possibly, yes. The new redis config might have changed the database file from "dump.rdb" to "redis.rdb". Go into /var/lib/redis and save a backup copy of dump.rdb, it's probably the bigger one (since the other one is empty).

    Then turn off redis: sudo stop redis-server

    Then check /etc/redis/redis.conf for the dbfilename option, and check that it is set to dump.rdb.

    Start redis: sudo start redis-server


Log in to reply
 


Looks like your connection to NodeBB was lost, please wait while we try to reconnect.