• Can't install on Centos 7 without errors. Followed official install doc:

    [[email protected] nodebb]# ./nodebb setup
    2022-08-08T14:20:34.071Z [29717] - info: NodeBB Setup Triggered via Command Line
    
    Welcome to NodeBB v2.3.1!
    
    This looks like a new installation, so you'll have to answer a few questions about your environment before we can proceed.
    Press enter to accept the default setting (shown in brackets).
    URL used to access this NodeBB (http://localhost:4567) 
    Please enter a NodeBB secret (dda0b5cb-9b9b-4587-b3d5-829e325e2c99) 
    Would you like to submit anonymous plugin usage to nbbpm? (yes) 
    Which database to use (mongo) 
    2022-08-08T14:20:43.027Z [29717] - info: 
    Now configuring mongo database:
    MongoDB connection URI: (leave blank if you wish to specify host, port, username/password and database individually)
    Format: mongodb://[username:[email protected]]host1[:port1][,host2[:port2],...[,hostN[:portN]]][/[database][?options]] 
    Host IP or address of your MongoDB instance (127.0.0.1) 
    Host port of your MongoDB instance (27017) 
    MongoDB username nodebb
    Password of your MongoDB database 
    MongoDB database name (nodebb) 
    2022-08-08T14:21:44.375Z [29717] - warn: NodeBB Setup Aborted.
     MongoServerSelectionError: connect ECONNREFUSED 127.0.0.1:27017
        at Timeout._onTimeout (/root/nodebb/node_modules/mongodb/lib/sdam/topology.js:293:38)
        at listOnTimeout (internal/timers.js:557:17)
        at processTimers (internal/timers.js:500:7)
    [[email protected] nodebb]# firewall-cmd --zone=public --add-port=4567/tcp --permanent
    -bash: firewall-cmd: command not found
    [[email protected] nodebb]# firewall-cmd --reload
    -bash: firewall-cmd: command not found
    [[email protected] nodebb]# ./nodebb start
    2022-08-08T14:22:31.089Z [29732] - info: Launching web installer on port 4567
    2022-08-08T14:22:42.084Z [29732] - info: Web installer listening on http://0.0.0.0:4567
    
  • Global Moderator Plugin & Theme Dev

    You selected mongo as your database but the instructions you linked install redis. If you wish to use mongo you'll need to install it and start the service. If you wish to use redis, you'll need to start the service and then select redis during setup.


  • @PitaJ Thanks, misread that step. Got it working now.


Suggested Topics

  • 2
  • 3
  • 5
  • 5
  • 6
| | |

Ā© 2014 ā€“ 2022 NodeBB, Inc. ā€” Made in Canada.