SOLVED New Install - Plugin Page Freezes

  • Global Moderator Plugin & Theme Dev

    @sampo2910 did you set up the built in SMTP emailer? You have to enable it and provide account details.

    Is your forum available publicly? Have you tried a different computer?


  • @pitaj Firefox was a test. I dont use it. I just downloaded the latest to try it. I use latest version as Chrome by default.

    But whatever browser I use it is the same. Problem must lie elsewhere.

    Regarding email and saying dont need to install anything why is that in the logs

    'The sendmail executable could not be found, please ensure it is installed and executable ' Permissions? And can i get 1 reputation point please lol....I have to keep waiting to post 🙂

    The forum does not crash when it is hanging...I have to close the page wait a minute and then go in again. It is only that 'find plugins page' NO WHERE else.

    SMTP settings have all the account details all set up. Like i said it worked before.

  • Community Rep

  • Global Moderator Plugin & Theme Dev

    @sampo2910 sendmail isn't necessary if you have SMTP set up. I just checked. If you share a screenshot of your emails settings page I can help you more.

    That's a different issue we can figure out later though. Let's focus on the problem at hand. You haven't really been answering my questions, please answer all questions I ask or I won't have enough information to help you.

    • Are you on NodeBB 1.18.3?
    • Is your forum available through the internet?
    • Have you tried using a different computer?
  • Community Rep

    @pitaj Well, from the error it would seem OP was trying to utilize the sendmail executable rather than the built-in, no? Which I presumed was purposeful since I don't think that is default? 🤔

  • Global Moderator Plugin & Theme Dev

    @gotwf sendmail is default if SMTP is not enabled. (which it by default is not)

  • Community Rep

    @pitaj "sendmail" the builtin nodejs stuff or "sendmail" the executable, as in Postfix drop in replacement? Postfix made things easy to replace Sendmail, the defacto default executable bitd in that regard but using the same name has led to confusion a time or two... Heck, I am not even sure I was clear enough in that howto. Maybe I need to reword some of that? 🤔

    I think you are using "sendmail" to reference the NodeBB built in. Just to clarify for those who may come to this thread later. 🐕 ✌

  • Global Moderator Plugin & Theme Dev

    @gotwf "sendmail" is an executable on your system. By default (when SMTP transport is disabled and there is no emailer plugin installed), NodeBB uses a sendmail transport provided by the nodemailer package. The sendmail transport will call the sendmail executable on the system, if it exists.

    I'm not referring to some NodeBB internal system. Generally we call the system in NodeBB which handles sending emails the "emailer".

  • Community Rep

    @pitaj Hmm... Does Debian still ship with Exim by default? Does Exim rename their executable to sendmail? I'd thought not but been a while since I used it. I think OP is using Ubuntu (wh/includes Postfix's sendmail executable as shipped). But they maybe on Deb? Just to clarify.

    Qmail would be another example of a Sendmail daemon replacement. Qmail executable is "qmail". Once upon a time pretty much the defacto replacement for Sendmail. Qmail does not call its executable "sendmail".

    Hence, although Postfix has evolved as the MTA of choice over the past couple decades it is not the only option. Options which do not rename their MTA binaries so maybe probing/checking for "sendmail" could be less than robust?

    Edit: Yeah, Debian does still include Exim by default https://wiki.debian.org/Exim


  • @pitaj said in New Install - Plugin Page Freezes:

    @sampo2910 sendmail isn't necessary if you have SMTP set up. I just checked. If you share a screenshot of your emails settings page I can help you more.

    That's a different issue we can figure out later though. Let's focus on the problem at hand. You haven't really been answering my questions, please answer all questions I ask or I won't have enough information to help you.

    • Are you on NodeBB 1.18.3?
    • Is your forum available through the internet?
    • Have you tried using a different computer?

    The very first time i set up nodebb i never had this issue at all. I have done same again...(this is 5th time to be sure) but this. Like i said all is fine on whole admin site apart from these two things. Freeze and Mail.

    Yes
    Yes
    Yes

    emailpage.png


  • I also noticed this.

    When i use ./nodebb stop should i be able to see the webpage?

    Because I can. Even if i clear browser cache etc i still see it. ?

    i tried going in ./nodebb dev also and noticed a message - error: NodeBB address in use, exiting...

    Is something using the address something happening twice ?


  • This is output from ./nodebb log:

    smiley@fmjcod4:~/nodebb$ ./nodebb log

    Hit Ctrl-C to exit

    Clustering enabled: Spinning up 1 process(es).

    2021-09-26T18:50:07.298Z [4567/7357] - info: Initializing NodeBB v1.18.3 http://localhost:4567
    2021-09-26T18:50:08.527Z [4567/7357] - info: [socket.io] Restricting access to origin: http://localhost😘
    2021-09-26T18:50:08.748Z [4567/7357] - info: [plugins/spam-be-gone] Settings loaded
    2021-09-26T18:50:08.766Z [4567/7357] - info: [api] Adding 0 route(s) to api/v3/plugins
    2021-09-26T18:50:08.778Z [4567/7357] - info: [router] Routes added
    2021-09-26T18:50:08.780Z [4567/7357] - info: NodeBB Ready
    2021-09-26T18:50:08.781Z [4567/7357] - info: Enabling 'trust proxy'
    2021-09-26T18:50:08.782Z [4567/7357] - info: NodeBB is now listening on: 0.0.0.0:4567

  • Global Moderator Plugin & Theme Dev

    Your screenshot doesn't include this toggle:
    1066246a-eb55-45c4-944b-acb0a1130aef-image.png
    Do you have it enabled as shown in the picture?

    When i use ./nodebb stop should i be able to see the webpage?

    No. You will need to use the command line to manually kill all node processes. Then you can ./nodebb start it back up.

  • Community Rep

    @sampo2910 Okay, from the screenshot posted above, you are relaying NodeBB email through a dedicated SMTP executable. If whatever that is, let us assume Postfix, the SMTPD (SMTP Daemon) should be logging attempted connections, typically to /var/log/maillog.

    Presuming you have access to the box where that daemon is running, tail that puppy:

    tail -f /var/log/maillog
    

    Then repeat whatever you do in NodeBB to trigger the NodeBB log smtp connection refused error. Observe the tail'd smtp daemon log. It should provide more detailed insight as to why the connection is being rejected. If not, increase "verbosity" of the postfix sendmail daemon and reload the config. Iirc you can even do from command line temporarily w/o having to edit the conf file but I forget the command off the top of my head. I think man postconf should get you there.

    Good luck o/

    P.S.; The above is predicated on you having selected Custom and then obfuscating your actual config via the smtp.mail.com example in your screenshot above. If not, see @PitaJ comment above.


  • @pitaj said in New Install - Plugin Page Freezes:

    Your screenshot doesn't include this toggle:
    1066246a-eb55-45c4-944b-acb0a1130aef-image.png
    Do you have it enabled as shown in the picture?

    When i use ./nodebb stop should i be able to see the webpage?

    No. You will need to use the command line to manually kill all node processes. Then you can ./nodebb start it back up.

    OMG how stupid do I feel now with the mail 'problem'. It was off! I toggled to on and email success and it came through.

    In my defence 🙂 I was also thinking that needed to be on if i used Gmail,Yahoo i.e. external email server. Of course how you read it. Happy that that side of live is working.

    Just this freezing problem on find plugins. I guess I have the main ones I need but maybe something else in there I would like also. But for now at least I can open up to registration etc with email working.


  • I am not sure if this has anything to do with but..as I said before if i run ./nodebb stop then i can still see my forum and navigate etc even after this. This is not right or am I stopping it wrong? I have not set nodebb up as a service yet.

    2021-09-27 15_19_27-Window.png

    I tried ./nodebb dev after and i get this: Not sure if you can see so linked a notepad text of the full output here

    Cant add files here.

    2021-09-27 15_21_09-Window.png

  • Global Moderator Plugin & Theme Dev

    @sampo2910 as I said, it looks like you have a rogue process. Sometimes one gets left behind and ./nodebb stop can't kill it. You'll need to manually kill it instead. It's easiest to kill all node processes. Then you'll be able to start it back up.


  • @pitaj Even if I reboot the machine this 'rogue' process will start again? How can I prevent that ?

    Best way to stop also please. I have one other application using node also.

    Thanks for all the help so far.

  • Global Moderator Plugin & Theme Dev

    @sampo2910

    Even if I reboot the machine this 'rogue' process will start again? How can I prevent that ?

    The only way this could happen is if you have a service set up or something. What OS are you on?

  • Global Moderator Plugin & Theme Dev

    @sampo2910 said in New Install - Plugin Page Freezes:

    OMG how stupid do I feel now with the mail 'problem'. It was off! I toggled to on and email success and it came through.

    In my defence 🙂 I was also thinking that needed to be on if i used Gmail,Yahoo i.e. external email server. Of course how you read it. Happy that that side of live is working.

    It enables the SMTP transport. It's necessary no matter what service you choose, including a custom one.

Suggested Topics

  • 28
  • 2
  • 4
  • 6
  • 9
| |