Missing many font awesome icons

Solved Technical Support

Suggested Topics

  • 0 Votes
    11 Posts

    far fa-pencil-ruler is a paid icon (the solid version is free). Free parts of the regular pack work just fine - see https://fontawesome.com/v5/search?m=free&s=regular for a list of them. It's much more limited than the solid free pack though (151 icons vs 1001), so that's probably why you ran into this problem so easily.

    The only issue that you might run into if you're using a version before v2.2.0 is that fab class conflicts with another class in Persona theme turning all brand icons into action buttons, but this is resolved in current versions of Persona.

    If you have a paid version of FA5 it should be fairly simple to use it instead - you'd need to replace the FA files in public/vendor/fontawesome with the new ones, set fa-font-path to vendor/fontawesome/webfonts in _variables.less and import the light and duotone less files in src/meta/css.js.

    Also, I wanted to add that FA6 is slated to be added in NodeBB 3.0 (it's waiting until a major release since icon style being changed is possibly breaking) https://github.com/NodeBB/NodeBB/pull/10701

  • 0 Votes
    16 Posts

    @kurulumu-net Welcome back sir 🙂

  • 0 Votes
    7 Posts

    @julian I confirm the issue is resolved, many thanks for the quick support ☺️

  • 0 Votes
    1 Posts

    I have upgraded my nodebb to v1.12.2 and I am using apache2 as a proxy (https://docs.nodebb.org/configuring/proxies/apache/) but there is an error in the console saying that translations are missing. I just can see the placeholder strings in my forum (remember_me etc.).

    The translation files are there, inside the public directory of my nodebb installation.

    The problem is that the directory assets does not exist. I tried to set a rewrite condition in the apache2 config file for my forum, in order to rewrite assets for public, but no success. Any help would be very much appreciated.

    UPDATE: ./nodebb log shows me the same Missing translation errors, so I guess it has nothing to do with Apache

    Update 2: I can also view the source of the translation files from the link prefetch.

    Update 3: it seems like it is only an issue when I am logged in as a user in my nodebb installation

    Update 4: the issue with only with the current admin user, and for some reason the language setting for this user, after updating nodebb, was set to a language which was not installed on my system. I set it to en-US and all is good now.

    Here is a screenshot:

    Screen Shot 2019-06-03 at 12.55.16.png

  • 0 Votes
    2 Posts

    This should be possible from the ACP, select an empty icon and change the text class so it is not visible-xs-inline