SSO on v1.17.0

Solved Technical Support
  • GNU/Linux

    I'm working up to upgrading from 1.14.3 to 1.17.0 and working through breaking issues. I looked at the breaking issues for 1.15, 1.16 and 1.17 and I didn't see anything obvious.

    First I had it with Github (v2.3.1)

    When I go to login, I got an error, so I removed that. Then I got the same error from v2.4.2:

    2021-05-12T17:31:56.251Z [4567/47491] - verbose: [plugins/fireHook] filter:middleware.buildHeader
    (node:47491) UnhandledPromiseRejectionWarning: TypeError: Cannot read property 'push' of undefined
        at Object.Google.appendUserHashWhitelist [as method] (/home/boomzilla/tdwtf/plugins/nodebb-plugin-sso-google/library.js:110:18)
        at /home/boomzilla/nodebb/src/plugins/hooks.js:131:29
        at new Promise (<anonymous>)
        at fireMethod (/home/boomzilla/nodebb/src/plugins/hooks.js:130:10)
        at Object.fireFilterHook [as filter] (/home/boomzilla/nodebb/src/plugins/hooks.js:149:18)
        at processTicksAndRejections (internal/process/task_queues.js:95:5)
        at async (/home/boomzilla/nodebb/src/plugins/hooks.js:99:17)
        at async User.getUsersFields (/home/boomzilla/nodebb/src/user/data.js:59:19)
        at async User.bans.unbanIfExpired (/home/boomzilla/nodebb/src/user/bans.js:111:20)
        at async User.bans.canLoginIfBanned (/home/boomzilla/nodebb/src/user/bans.js:96:23)

    Where do I go from here?

  • NodeBB

    @boomzilla said in SSO on v1.17.0:


    Latest is 2.5.3

  • GNU/Linux

    @baris d'oh! I could have sworn that I'd updated them all to latest.


Suggested Topics

| | | |