Emoji problem

Technical Support
  • @pitaj
    I tried to run the command I said in the command line.

    
    C:\Windows\system32>CD NODEBB
    
    C:\Windows\System32\nodebb>db.objects.update({ _key:'emoji:customizations:emojis' }, { $set: { _key: 'emoji:customizations:emojis:bkp' } }, { multi: true })
    'db.objects.update' is not recognized as an internal or external command,
    operable program or batch file.
    
    C:\Windows\System32\nodebb>
    
    

    This is the output.

    Surely it should be done differently. I would love if you could explain to me how I should do this ??
    Run in a 'jet'
    Or without CD NODEBB

  • @chez it needs to be executed in a mongo cli shell:

    https://community.nodebb.org/post/81728

  • @pitaj
    I ran the command.
    Surprisingly did not help at all.
    Anyway thank you for helping so willingly.

    馃憤 馃憤

  • @chez

    I wonder what happened here
    I uninstalled the Android package and installed the "nodebb-plugin-emoji-one" package and the emoji works for me.

    But the "Edit" button does not work for me.

    d904f6e3-9b36-42aa-9740-6042e1324c31-转诪讜谞讛.png

  • @chez

    I ran the command

    Step me through exactly what you did.

    What's the output of the following?

    mongo
    
    > use <your nodebb database name>
    > db.objects.find({ _key:'emoji:customizations:emojis' })
    > db.objects.find({ _key:'emoji:customizations:adjuncts' })
    

    I uninstalled the Android package and installed the "nodebb-plugin-emoji-one" package and the emoji works for me.

    Weird.

  • @pitaj said in Emoji problem:

    转讚专讬讱 讗讜转讬 讘讚讬讜拽 诪讛 砖注砖讬转.

    I ran the command I was told as follows:

    I opened cmd as a manager>
    mongo>

    db.objects.update ({_key: 'emoji: customizations: emojis'}, {$ set: {_key: 'emoji: customizations: emojis: bkp'}}, {multi: true})
    

    After to no avail, I removed the android and it worked for me
    It turned out that probably in one of the experimental stages I installed the replacement emoji plugin "nodebb-plugin-emoji-one"

    @pitaj said in Emoji problem:

    诪讛 讛转驻讜拽讛 砖诇 讛讚讘专讬诐 讛讘讗讬诐?

    Microsoft Windows [Version 10.0.19042.928]
    (c) Microsoft Corporation. 讻诇 讛讝讻讜讬讜转 砖诪讜专讜转.
    
    C:\Windows\system32>mongo
    MongoDB shell version v4.2.6
    connecting to: mongodb://127.0.0.1:27017/?compressors=disabled&gssapiServiceName=mongodb
    Implicit session: session { "id" : UUID("cda2452c-954a-4b0e-b086-5e6a6d4164fa") }
    MongoDB server version: 4.2.6
    Server has startup warnings:
    2021-05-09T08:00:56.911+0300 I  CONTROL  [initandlisten]
    2021-05-09T08:00:56.911+0300 I  CONTROL  [initandlisten] ** WARNING: Access control is not enabled for the database.
    2021-05-09T08:00:56.912+0300 I  CONTROL  [initandlisten] **          Read and write access to data and configuration is unrestricted.
    2021-05-09T08:00:56.912+0300 I  CONTROL  [initandlisten]
    ---
    Enable MongoDB's free cloud-based monitoring service, which will then receive and display
    metrics about your deployment (disk utilization, CPU, operation statistics, etc).
    
    The monitoring data will be available on a MongoDB website with a unique URL accessible to you
    and anyone you share the URL with. MongoDB may use this information to make product
    improvements and to suggest MongoDB products and deployment options to you.
    
    To enable free monitoring, run the following command: db.enableFreeMonitoring()
    To permanently disable this reminder, run the following command: db.disableFreeMonitoring()
    ---
    
    > > use <your nodebb database name>
    ... > db.objects.find({ _key:'emoji:customizations:emojis' })
    2021-05-10T08:54:11.203+0300 E  QUERY    [js] uncaught exception: SyntaxError: expected expression, got '>' :
    @(shell):1:0
    > > db.objects.find({ _key:'emoji:customizations:adjuncts' })
    2021-05-10T08:54:34.051+0300 E  QUERY    [js] uncaught exception: SyntaxError: expected expression, got '>' :
    @(shell):1:0
    >
    
  • @chez said in Emoji problem:

    I opened cmd as a manager>
    mongo>

    db.objects.update ({_key: 'emoji: customizations: emojis'}, {$ set: {_key: 'emoji: customizations: emojis: bkp'}}, {multi: true})
    

    You can't add spaces like that after each : and after the $. If that is exactly what you put it, it wouldn't work and would probably result in an error.

    > > db.objects.find({ _key:'emoji:customizations:adjuncts' })
    2021-05-10T08:54:34.051+0300 E  QUERY    [js] uncaught exception: SyntaxError: expected expression, got '>' :
    @(shell):1:0
    

    You're not supposed to actually type the > at the beginning of the line. That's just to signify you're in the mongo shell. You also need to replace <your nodebb database name> with the name of the database sweet up for NodeBB. Like this:

    use nodebb
    db.objects.find({ _key:'emoji:customizations:emojis' })
    db.objects.find({ _key:'emoji:customizations:adjuncts' })
    
  • @pitaj
    This is the output

    > use admin
    switched to db admin
    > db.objects.find({ _key:'emoji:customizations:emojis' })
    > db.objects.find({ _key:'emoji:customizations:adjuncts' })
    { "_id" : ObjectId("60904e5677a9ae063f245948"), "_key" : "emoji:customizations:adjuncts", "value" : "{\"name\":\"stars\",\"ascii\":[\"诇讬讬拽\"]}", "score" : 13 }
    { "_id" : ObjectId("60904a8977a9ae063f2457d6"), "_key" : "emoji:customizations:adjuncts", "value" : "{\"name\":\"+1\",\"ascii\":[\"诇讬讬拽\"]}", "score" : 12 }
    { "_id" : ObjectId("60904cae77a9ae063f245899"), "_key" : "emoji:customizations:adjuncts", "value" : "{\"name\":\"100\",\"ascii\":[\"诇讬讬讬拽\"]}", "score" : 11 }
    { "_id" : ObjectId("60904c3277a9ae063f245871"), "_key" : "emoji:customizations:adjuncts", "value" : "{\"name\":\"+1\",\"aliases\":[\":讻诪讜\"],\"ascii\":[\"诇讬讬拽\"]}", "score" : 10 }
    { "_id" : ObjectId("60904b3c77a9ae063f245827"), "_key" : "emoji:customizations:adjuncts", "value" : "{\"name\":\"+1\",\"ascii\":[\"诇讬讬拽\",\":讻诪讜\",\":转讜讚讛\"]}", "score" : 8 }
    { "_id" : ObjectId("60904ad977a9ae063f2457ff"), "_key" : "emoji:customizations:adjuncts", "value" : "{\"name\":\"+1\",\"aliases\":[\"诇讬讬拽\"],\"ascii\":[\"诇讬讬拽\"]}", "score" : 6 }
    { "_id" : ObjectId("60904a6777a9ae063f2457b3"), "_key" : "emoji:customizations:adjuncts", "value" : "{\"name\":\"+1\",\"ascii\":[\"诇讬讬拽\",\":转讜讚讛\",\":讻诪讜\"]}", "score" : 4 }
    { "_id" : ObjectId("60904a3077a9ae063f245774"), "_key" : "emoji:customizations:adjuncts", "value" : "{\"name\":\"+1\",\"ascii\":[\"诇讬讬拽\",\":转讜讚讛\"]}", "score" : 3 }
    
    
    

    It should be noted that the problem started when I tried to make a custom emoji
    In an option that allows you to write a word, for example, that when a user writes it, the emoji I selected will appear
    Thank you so much for the help !!

  • Okay try running this in a mongo shell like before:

    db.objects.update({ _key:'emoji:customizations:adjuncts' }, { $set: { _key: 'emoji:customizations:adjuncts:bkp' } }, { multi: true })
    
  • @pitaj said in Emoji problem:

    Okay try running this in a mongo shell like before:

    db.objects.update({ _key:'emoji:customizations:adjuncts' }, { $set: { _key: 'emoji:customizations:adjuncts:bkp' } }, { multi: true })
    

    I did as you told me and the problem worked out 馃槉

    I thank you very much 馃憤馃憤馃憤


Suggested Topics


  • 0 Votes
    7 Posts
    392 Views

    @DownPW I see what you mean, yes. I thought you'd made a typo... 馃檪

  • 0 Votes
    1 Posts
    758 Views

    After installing NodeBB I've been trying to configure Emoji. I've installed nodebb-plugin-emoji-extended and nodebb-plugin-emoji-one through the admin interface and have also activated them. But in the front-end the smiley selection button above the messages box does not appear.

    I've tried running "Update Files" in the ACP, which doesn't seem to be working. Popping up the console, I see various errors stating "GET http://95.85.57.198:4567/socket.io/?EIO=3&transport=polling&t=LYgu_ke net::ERR_CONNECTION_REFUSED" (from acp.min.js?v=a114ca78-1b00-48b4-8cb1-6d5fb06836f3:5).

    Help would be much appreciated.

  • Upgrade problem

    Solved Technical Support
    0 Votes
    2 Posts
    1k Views

    npm unl nodebb-theme-cerulean && ./nodebb upgrade

  • 0 Votes
    6 Posts
    2k Views
    I'm updating any plug-in. I'm throwing reset the system. Then I get a 502 error. Log as follows. Upgrade learn everything by going into the past.

    [cluster] Child Process (14718) has exited (code: 0, signal: null)

    24/8 12:32 [25466] - info: Time: Mon Aug 24 2015 12:32:01 GMT-0400 (EDT)

    24/8 12:32 [25466] - info: Initializing NodeBB v0.7.3

    Warning: Redis server does not require a password, but a password was supplied.

    Warning: Redis server does not require a password, but a password was supplied.

    Warning: Redis server does not require a password, but a password was supplied.

    [outdated] nodebb-plugin-composer-default v1.0.11, requires 1.0.9

    24/8 12:32 [25466] - warn: One or more of NodeBB's dependent packages are out-of-date. Please run the following command to update them:

    24/8 12:32 [25466] - warn: ./nodebb upgrade

    [cluster] Child Process (25466) has exited (code: 0, signal: null)

  • 0 Votes
    2 Posts
    2k Views

    In nodebb:

    Admin > Location & APIs > SSO > Twitter > Add new api token.

    In Twitter:

    (User menu > Settings > API > generate SSO.