[nodebb-plugin-poll] Poll plugin


  • GNU/Linux

    @Tom_Rade Thanks man, it's working perfectly!
    It's just a shame that isn't on GitHub, people would see it better... I will paste this link you gave me on my pull request on Schamper's repo



  • @jtsimoes At some point I'll upload it to GitHub. Tho I'm very unexperienced.


  • GNU/Linux

    Hey!
    I get a issue while I creating a post with poll

    E11000 duplicate key error collection: mo_nodebb.objects index: _key_1_value_-1 dup key: { : "poll:34:options", : null }
    

    I tried reinstall plugin and even a NodeBB but still the same issue.
    Version of NodeBB: v1.12.2
    Version of Plugin: 0.2.20

    Any ideas? Thanks for help 🙂



  • same problem
    any solution?
    @Schamper Is this project abandoned?

    alt text


  • GNU/Linux

    @arranka Do you use Mongo or Redis?



  • @Gremek said in [nodebb-plugin-poll] Poll plugin:

    @arranka Do you use Mongo or Redis?

    mongo


  • GNU/Linux

    @arranka Seems to be Mongo issue, because my friend which use Redis doesn't have problem with this plugin (but I'm not sure, this is only my hypothesis)


  • GNU/Linux

    @Gremek I confirm. All good using Redis


  • GNU/Linux

    @akhoury Maybe you know where is a problem?



  • I believe this was already reported and fixed, see: https://github.com/NodeBB/nodebb-plugin-poll/issues/96

    Issue is, the fix was made to the master branch, si it is not in the latest release.



  • There are some errors after updating this plugin to the latest version:

    2019-07-14T19:58:54.623Z [4567/28794] - info: Initializing NodeBB v1.12.2 https://domain.tld
    [benchpressjs] Unable to build or find a suitable native module, falling back to JS version
    2019-07-14T19:58:56.613Z [4567/28794] - error: Your NodeBB schema is out-of-date. Please run the following command to bring your dataset up to spec:
    2019-07-14T19:58:56.613Z [4567/28794] - error:     ./nodebb upgrade
    [cluster] Child Process (28794) has exited (code: 0, signal: null)
    

    OK, I tried to upgrade:

    ./nodebb upgrade
    
    Updating NodeBB...
    
    1. Updating package.json file with defaults...  OK
    
    2. Bringing base dependencies up to date...  started
    npm WARN textcomplete.contenteditable@0.1.1 requires a peer of textcomplete@^0.14.2 but none is installed. You must install peer dependencies yourself.
    
    audited 5014 packages in 10.897s
    found 22 vulnerabilities (2 low, 4 moderate, 16 high)
      run `npm audit fix` to fix them, or `npm audit` for details
    
    3. Checking installed plugins for updates...  OK
    4. Updating NodeBB data store schema...[benchpressjs] Unable to build or find a suitable native module, falling back to JS version
    
    Parsing upgrade scripts... 
    
    OK | 1 script(s) found, 77 skipped
      → [2019/4/1] Convert all poll id votes and options votes to sorted sets...
    Error occurred
    Error occurred during upgrade: ReplyError: WRONGTYPE Operation against a key holding the wrong kind of value
        at parseError (/var/www/myforum.tld/nodebb/node_modules/redis-parser/lib/parser.js:193:12)
        at parseType (/var/www/myforum.tld/nodebb/node_modules/redis-parser/lib/parser.js:303:14)
    2019-07-14T20:12:06.661Z [4567/28935] - error: uncaughtException: WRONGTYPE Operation against a key holding the wrong kind of value
    ReplyError: WRONGTYPE Operation against a key holding the wrong kind of value
        at parseError (/var/www/myforum.tld/nodebb/node_modules/redis-parser/lib/parser.js:193:12)
        at parseType (/var/www/myforum.tld/nodebb/node_modules/redis-parser/lib/parser.js:303:14) {"error":{"command":"ZCOUNT","args":["poll:1:options:2:votes","-inf","+inf"],"code":"WRONGTYPE"},"stack":"ReplyError: WRONGTYPE Operation against a key holding the wrong kind of value\n    at parseError (/var/www/myforum.tld/nodebb/node_modules/redis-parser/lib/parser.js:193:12)\n    at parseType (/var/www/myforum.tld/nodebb/node_modules/redis-parser/lib/parser.js:303:14)","exception":true,"date":"Sun Jul 14 2019 23:12:06 GMT+0300 (Eastern European Summer Time)","process":{"pid":28935,"uid":0,"gid":0,"cwd":"/var/www/myforum.tld/nodebb","execPath":"/usr/local/bin/node","version":"v10.15.3","argv":["/usr/local/bin/node","/var/www/myforum.tld/nodebb/nodebb","upgrade"],"memoryUsage":{"rss":126144512,"heapTotal":103751680,"heapUsed":68242168,"external":451882}},"os":{"loadavg":[1.353515625,0.51025390625,0.35888671875],"uptime":693319},"trace":[{"column":12,"file":"/var/www/myforum.tld/nodebb/node_modules/redis-parser/lib/parser.js","function":"parseError","line":193,"method":null,"native":false},{"column":14,"file":"/var/www/myforum.tld/nodebb/node_modules/redis-parser/lib/parser.js","function":"parseType","line":303,"method":null,"native":false}]}
    

    Please, help me to fix this errors,


  • Global Moderator

    @almond those errors don't seem to be related to any specific plugin.



  • @PitaJ, however, after removing this plugin, there are no such errors.
    I was forced to roll back to the previous version (nodebb-plugin-poll2).


Log in to reply
 

Suggested Topics

| |