Installing as newbie - nodebb command not found

Technical Support
  • #1

    Hi, I've following the install steps and now at the step where I need to run setup. However, when I'm in the /nodebb directory, when ls the directory I can see a green "nodebb" perl script and when I look at the directory in the file manager I can see "nodebb" is in fact there and it shows it as a perl script.

    I just ran the following -

    [email protected]:~/work/nodebb/nodebb$ ls
    app.js          docker-compose.yml  Gruntfile.js  LICENSE    logs    nodebb.bat      require-main.js  test
    build   commitlint.config.js  Dockerfile          install       loader.js  nodebb  public      renovate.json  src
    [email protected]:~/work/nodebb/nodebb$ nodebb setup
    nodebb: command not found

    Yes I know I have two directories named the same, I created the directory for node before I ran the git clone which created the identical folder as well.

    At any rate, I tried running as 'sudo' but according to the docs I've read seems that's not correct way to run nodebb. But, in both cases it says it can't find the program.

    Huh? 🙂 Thanks for any help

  • Global Moderator Plugin & Theme Dev

    It's ./nodebb, not nodebb. The ./ is necessary.

  • #3

    Ok great, thanks!

Suggested Topics

| | | |