Cannot update General settings in admin panel

  • Errors in the browser console:

    WebSocket connection to 'wss://' failed: Error during WebSocket handshake: Unexpected response code: 502

    currently using Nginx as a proxy server, and also tried others.

    please help find out what's wrong, I've been worked on this thing 5 hours.

    35363914-165a-4580-b727-e0fabfd8a2c9-image.png then e9598f91-eba3-4fbc-85f1-5054fb5f454e-image.png

  • Global Moderator

    What's your nginx config? What version of NodeBB, node.js, database?

  • @PitaJ

    NodeBB: 1.14.2
    Nodejs: 12.18.3
    Database: Mongodb 4.2.8
    Nginx config:

    server {
        listen 80;
        location / {
            proxy_set_header X-Real-IP $remote_addr;
            proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
            proxy_set_header X-Forwarded-Proto $scheme;
            proxy_set_header Host $http_host;
            proxy_set_header X-NginX-Proxy true;
            proxy_redirect off;
            # Socket.IO Support
            proxy_http_version 1.1;
            proxy_set_header Upgrade $http_upgrade;
            proxy_set_header Connection "upgrade";

  • @PitaJ

    Here is the full image of my error.

    My network structure is: CDN (using HTTPS but HTTP to origin) =====> Nginx Proxy =====> NodeBB


    do you guys have discord or telegram group?

    It's hard to communicate through a forum.

  • Global Moderator

    What CDN? Some don't support forwarding Websockets. Have you tried it without the CDN?

    We prefer to have conversation on the open forum as hopefully others with similar issues can find their solutions by looking back at previous posts in the future.

  • @PitaJ

    I'm pretty sure about my CDN provider supports WebSocket forwarding, all of my other functions worked except General Settings.

  • Global Moderator

    Have you recently upgraded from an older nodebb? What's the output of git status?

  • Global Moderator

    I assume you've tried rebuilding and restarting.

    That's the whole git status? Nothing about untracked files?

    Can you try upgrading to the latest 1.14.x and trying that?

    I must be missing something. I see no reason why settings/general shouldn't work like everything else.

    Have you tried it without the CDN?

Suggested Topics

| |