After update Error ENONET

Technical Support

Suggested Topics


  • emoji error

    Unsolved Technical Support
    0 Votes
    2 Posts
    246 Views

    @fly777 maybe. Try going to Admin > plugins> emoji and build emoji assets and rebuild and restart forum

  • 0 Votes
    7 Posts
    5k Views

    @pitaj

    The plugin was indeed in the dependencies section even though it was not installed on my nodeBB instance, weird.

    Removing it has fixed the error. Thank you so much for your help 🙂

    Here's how the package.json file looked like:

    { "name": "nodebb", "license": "GPL-3.0", "description": "NodeBB Forum", "version": "1.16.1", "homepage": "http://www.nodebb.org", "repository": { "type": "git", "url": "https://github.com/NodeBB/NodeBB/" }, "main": "app.js", "scripts": { "start": "node loader.js", "lint": "npx eslint --cache ./nodebb .", "test": "npx nyc --reporter=html --reporter=text-summary npx mocha", "coverage": "nyc report --reporter=text-lcov > ./coverage/lcov.info", "coveralls": "nyc report --reporter=text-lcov | coveralls && rm -r coverage" }, "husky": { "hooks": { "pre-commit": "npx lint-staged", "commit-msg": "npx commitlint -E HUSKY_GIT_PARAMS" } }, "lint-staged": { "*.js": [ "eslint --fix", "git add" ] }, "dependencies": { "@adactive/bootstrap-tagsinput": "^0.8.2", "@nodebb/bootswatch": "3.4.2", "ace-builds": "^1.4.9", "archiver": "^5.0.0", "async": "^3.2.0", "autoprefixer": "10.2.0", "bcryptjs": "2.4.3", "benchpressjs": "2.4.0", "body-parser": "^1.19.0", "bootbox": "4.4.0", "bootstrap": "^3.4.1", "chart.js": "^2.9.3", "cli-graph": "^3.2.2", "clipboard": "^2.0.6", "colors": "^1.4.0", "commander": "^6.0.0", "compare-versions": "3.6.0", "compression": "^1.7.4", "connect-ensure-login": "^0.1.1", "connect-flash": "^0.1.1", "connect-mongo": "3.2.0", "connect-multiparty": "^2.2.0", "connect-pg-simple": "^6.1.0", "connect-redis": "5.0.0", "cookie-parser": "^1.4.5", "cron": "^1.8.2", "cropperjs": "^1.5.6", "csurf": "^1.11.0", "daemon": "^1.1.0", "diff": "^5.0.0", "express": "^4.17.1", "express-session": "^1.17.0", "express-useragent": "^1.0.13", "graceful-fs": "^4.2.3", "helmet": "^4.0.0", "html-to-text": "6.0.0", "ipaddr.js": "^2.0.0", "jquery": "3.5.1", "jquery-deserialize": "2.0.0-rc1", "jquery-form": "4.3.0", "jquery-serializeobject": "1.0.0", "jquery-ui": "1.12.1", "jsesc": "3.0.2", "json2csv": "5.0.5", "jsonwebtoken": "^8.5.1", "less": "^3.11.1", "lodash": "^4.17.15", "logrotate-stream": "^0.2.6", "lru-cache": "6.0.0", "material-design-lite": "^1.3.0", "mime": "^2.4.4", "mkdirp": "^1.0.4", "mongodb": "3.6.3", "morgan": "^1.10.0", "mousetrap": "^1.6.5", "nconf": "^0.11.0", "nodebb-plugin-composer-default": "6.5.5", "nodebb-plugin-dbsearch": "4.1.2", "nodebb-plugin-emoji": "^3.3.0", "nodebb-plugin-emoji-android": "2.0.0", "nodebb-plugin-gamification": "^1.0.1", "nodebb-plugin-markdown": "8.12.4", "nodebb-plugin-mentions": "2.13.6", "nodebb-plugin-question-and-answer": "^0.7.7", "nodebb-plugin-require": "0.0.6", "nodebb-plugin-seo": "^1.0.0", "nodebb-plugin-seo-slug-friendly": "0.0.8", "nodebb-plugin-seo-thread": "^0.1.10", "nodebb-plugin-soundpack-default": "1.0.0", "nodebb-plugin-spam-be-gone": "0.7.7", "nodebb-rewards-essentials": "0.1.4", "nodebb-theme-lavender": "5.0.17", "nodebb-theme-persona": "10.3.17", "nodebb-theme-slick": "1.3.7", "nodebb-theme-vanilla": "11.3.10", "nodebb-widget-essentials": "5.0.2", "nodemailer": "^6.4.6", "nprogress": "0.2.0", "passport": "^0.4.1", "passport-http-bearer": "^1.0.1", "passport-local": "1.0.0", "pg": "^8.0.2", "pg-cursor": "^2.1.9", "postcss": "8.1.10", "postcss-clean": "1.1.0", "promise-polyfill": "^8.1.3", "prompt": "^1.0.0", "redis": "3.0.2", "request": "2.88.2", "request-promise-native": "^1.0.8", "requirejs": "2.3.6", "rimraf": "3.0.2", "rss": "^1.2.2", "sanitize-html": "^2.0.0", "semver": "^7.2.1", "serve-favicon": "^2.5.0", "sharp": "0.27.0", "sitemap": "^6.1.0", "slideout": "1.0.1", "socket.io": "3.0.5", "socket.io-adapter-cluster": "^1.0.1", "socket.io-client": "3.0.5", "socket.io-redis": "6.0.1", "sortablejs": "1.10.2", "spdx-license-list": "^6.1.0", "spider-detector": "2.0.0", "textcomplete": "^0.17.1", "textcomplete.contenteditable": "^0.1.1", "timeago": "^1.6.7", "tinycon": "0.6.8", "toobusy-js": "^0.5.1", "uglify-es": "^3.3.9", "validator": "13.5.2", "visibilityjs": "2.0.2", "winston": "3.3.3", "xml": "^1.0.1", "xregexp": "^4.3.0", "zxcvbn": "^4.4.2" }, "devDependencies": { "@apidevtools/swagger-parser": "10.0.2", "@commitlint/cli": "11.0.0", "@commitlint/config-angular": "11.0.0", "coveralls": "3.1.0", "eslint": "7.17.0", "eslint-config-airbnb-base": "14.2.1", "eslint-plugin-import": "2.22.1", "grunt": "1.3.0", "grunt-contrib-watch": "1.1.0", "husky": "4.3.6", "jsdom": "16.4.0", "lint-staged": "10.5.3", "mocha": "8.2.1", "mocha-lcov-reporter": "1.3.0", "nyc": "15.1.0", "smtp-server": "3.8.0" }, "bugs": { "url": "https://github.com/NodeBB/NodeBB/issues" }, "engines": { "node": ">=10" }, "maintainers": [ { "name": "Andrew Rodrigues", "email": "[email protected]", "url": "https://github.com/psychobunny" }, { "name": "Julian Lam", "email": "[email protected]", "url": "https://github.com/julianlam" }, { "name": "Barış Soner Uşaklı", "email": "[email protected]", "url": "https://github.com/barisusakli" } ], "nyc": { "exclude": [ "src/upgrades/*", "test/*" ] } }
  • Error in console.

    Technical Support
    0 Votes
    7 Posts
    1k Views

    @RikoDEV

    Why shouldn't I use sudo to run NodeBB?

    You do not want to run NodeBB using sudo because this causes NodeBB to be run via the root user. This superuser has complete access to the entire system and should NodeBB ever become compromised, then a malicious user can utilise NodeBB as an attack vector to take over your system.

    Secondary effects from running NodeBB under sudo include the changing of ownership of some files to root, which would complicate administration of your NodeBB further as future starts of NodeBB will fail with an EACCES error, simply because some files could not be written to, as they are now owned by root instead of the regular user!

    Best practice security recommends running NodeBB with as few privileges as possible (ideally, nobody:nogroup), but practically an unprivileged user is perfectly fine.

    By the way, this also means running NodeBB as a user that has sudo access is also insecure. Just some food for thought.

  • Update vendors libs

    Technical Support
    0 Votes
    1 Posts
    673 Views

    Hi everybody!
    I want to suggest to upgrade vendor libs (you have old libs versions.). I tested replacement libs to new versions. Here is the result:

    public/vendor/ace public/vendor/bootbox/ [update: no] public/vendor/bootstrap/ [update: ok (interface lags? https://github.com/twbs/bootstrap/issues/18777)] public/vendor/buzz/ [update: ok] public/vendor/colorpicker/ [update: no] public/vendor/fontawesome/ [update: ok] public/vendor/mdl/ [update: ok] public/vendor/requirejs/ [update: ok] public/vendor/semver/ [update: no] public/vendor/slideout/ [update: js error] public/vendor/snackbar/ [update: js error] public/vendor/tinycon/ [update: js error] public/vendor/visibility/ [update: ok] public/vendor/xregexp/ [update: js error] public/vendor/jquery/bootstrap-tagsinput/ [update: no] public/vendor/jquery/css/ public/vendor/jquery/deserialize/ [update: ok] public/vendor/jquery/draggable-background/ [update: no] public/vendor/jquery/event/ [update: no] public/vendor/jquery/js/ (jquery - update: ok | jquery.form.min - update: ok) public/vendor/jquery/serializeObject/ [update: no] public/vendor/jquery/sortable/ [update: ok] public/vendor/jquery/textcomplete/ [update: ok] public/vendor/jquery/timeago/ [update: ok] public/vendor/autosize.js [update: no] public/vendor/nprogress.min.js [update: js error]