Daily Digest bug



  • Hi, I noticed in my Digest it says:

    digest.title in the email:

    82897aad-cedd-47a8-9985-4e18fbc0af68-image.png

    Where is this changed at? I looked under Manage/Digest and nothing there, and also could not find anything in the Settings section?

    Thanks


  • Admin Staff

    It should be one of

    "digest.title.day": "Your Daily Digest",
    "digest.title.week": "Your Weekly Digest",
    "digest.title.month": "Your Monthly Digest",
    

    Can you check if your language file has this at public/language/en-GB/email.json



  • Hi @baris

    Sorry, I am not clear on how to set the digest title, are you saying I should add those 3 lines to the email.json file you referenced?

    Thanks
    Duane


  • Admin Staff

    No, those 3 lines should already be in the email.json file.


  • GNU/Linux Admin

    @dcook, did you by any chance customize your email digest template in the ACP? You should revert any changes (or set it back to the default) from Settings -> Email. I think it is referencing an old language tag digest.title, which we do not use any longer.



  • Hi, I am not seeing any Digest settings in Settings / Email other than this:

    e8a140cf-f6e6-4552-907f-5ea119f3e0b8-image.png


  • GNU/Linux Admin

    Hm, what version of core and persona theme are you running?



  • You are running NodeBB v1.13.0

    nodebb-theme-persona
    Persona theme for NodeBB
    Installed 10.1.27 | Latest 10.1.27


  • GNU/Linux Admin

    Right... in that settings/email page, there should be a big black text box for you to customize the template.

    Use the dropdown to change the template to the digest template, and then revert it back to the default template... I'm thinking there might be a custom template set.


  • Swedes

    So, we have some modifications to the visual style of the template. Since emails can be a bit tricky to work with I just changed the template tag to [[email:digest.title.{interval}]]. But instead of showing up as digest.title in the emails sent, it now shows up as digest.title.alltime.

    Screenshot 2020-04-06 at 10.05.59.png

    I only tried to send a test email so maybe that's the issue. Should I report this as an issue? I guess email:digest.title.alltime should be added to the appropriate language file.


  • GNU/Linux Admin

    No, I think that is actually okay. In the emails we send out, we pass in day, week, or month depending on the digest. For the test email, the value alltime is sent in, purely so the digest is populated with something.

    We just don't happen to have a language tag for alltime 😄


  • Swedes

    Great, then there shouldn't be any issues when the digests are sent for real.


Log in to reply
 

Suggested Topics

| |