NodeBB, Docker-Compose, MongoDB, Nginx - Only showing Login/Register and NodeBB name



  • Hey all,
    I have been trying to get this working using a Docker-Compose setup and have got it all working (for the most part) minus when I go to the site it only shows Login/Register and NodeBB as seen below:

    alt text

    The Register button works but it is cut-off:

    alt text

    I am not sure if perhaps it has anything to do with the persistent data volumes? When I was just using the http://ServerIP:4567 it worked fine, but then I implemented the Nginx config (using Virtualmin, PHP-FPM, I had tried FCGId first but I seem to recall something somewhere said it was best to use FPM when doing reverse-proxy and virtualhosts. It worked the same either way, though) and am now using a domain, at the same time is when I implemented the named volumes. At first I was just using:

    
            version: '3.7'
    
            services:
                nodebb:        
                    image: nodebb/docker:latest
                    container_name: hpcs_nodebb
                    command: bash -c "./nodebb upgrade" # Used once at first because of schema/update needed 
                    ports:
                        - "4567:4567"
                    depends_on:
                        - mongodb
                    volumes:
                        - nodebb_init:/docker-entrypoint-initdb.d/
                        # This was the original way I had them all setup
                        - /home/<user>/devtools/site_files/nodebb/nodebb-config/config.json:/usr/src/app/config.json 
                        # This was how I ended up changing it
                        - nodebb_build:/usr/src/app/build
                        - nodebb_public:/usr/src/app/public
    
            volumes:
                nodebb_init:
                    driver: local
                    driver_opts:
                    o: bind
                    device: /home/<user>/devtools/site_files/nodebb/nodebb-init
                nodebb_build:
                    driver: local
                    driver_opts:
                    o: bind
                    device: /home/<user>/devtools/site_files/nodebb/nodebb-data/build
                nodebb_public:
                    driver: local
                    driver_opts:
                    o: bind
                    device: /home/<user>/devtools/site_files/nodebb/nodebb-data/public
    
    

    So I guess my question is, has anyone came across a similar situation or perhaps has any suggestions?
    Thanks!
    -MH


  • Global Moderator

    It's almost certainly due to a build issue. Can you look at the log?



  • Before I read this I tried a few more times to wipe out the images I had and repull them from nodebb/docker:latest but now I just get this over and over.

    nodebb exited with code 1
    nodebb      | module.js:550
    nodebb      |     throw err;
    nodebb      |     ^
    nodebb      | 
    nodebb      | Error: Cannot find module '../public/src/utils'
    nodebb      |     at Function.Module._resolveFilename (module.js:548:15)
    nodebb      |     at Function.Module._load (module.js:475:25)
    nodebb      |     at Module.require (module.js:597:17)
    nodebb      |     at require (internal/module.js:11:18)
    nodebb      |     at Object.<anonymous> (/usr/src/app/src/utils.js:3:18)
    nodebb      |     at Module._compile (module.js:653:30)
    nodebb      |     at Object.Module._extensions..js (module.js:664:10)
    nodebb      |     at Module.load (module.js:566:32)
    nodebb      |     at tryModuleLoad (module.js:506:12)
    nodebb      |     at Function.Module._load (module.js:498:3)
    

    The time before that it kept saying:

    nodebb  | /bin/sh: 1: ./nodebb: not found
    nodebb  | /bin/sh: 1: ./nodebb: not found
    nodebb  | /bin/sh: 1: ./nodebb: not found
    nodebb  | /bin/sh: 1: ./nodebb: not found
    

    I am trying to see if I can figure out how to build it from the github repo perhaps, instead of trying to do it from nodebb/docker repo. Not sure if that might help?



  • Edit : I gave it a few minutes after restarting Nginx and it looks like using the files from Github was my fix, looks to be that everything is working now!

    After doing a git clone of the current repo and building with the Dockerfile as opposed to just using the currently available nodebb/docker on docker hub, it looks like those issues went away. It currently isn't displaying anything at all right now, but in the logs I see:

    nodebb      | 
    nodebb      | Starting NodeBB
    nodebb      |   "./nodebb stop" to stop the NodeBB server
    nodebb      |   "./nodebb log" to view server output
    nodebb      |   "./nodebb help" for more commands
    nodebb      | 
    nodebb      | NodeBB v1.12.0 Copyright (C) 2013-2014 NodeBB Inc.
    nodebb      | This program comes with ABSOLUTELY NO WARRANTY.
    nodebb      | This is free software, and you are welcome to redistribute it under certain conditions.
    nodebb      | For the full license, please visit: http://www.gnu.org/copyleft/gpl.html
    nodebb      | 
    nodebb      | Clustering enabled: Spinning up 1 process(es).
    nodebb      | 2019-04-04T22:33:50.921Z [4567/22] - info: Initializing NodeBB v1.12.0 https://forum.mysite.dev
    nodebb      | 2019-04-04T22:33:54.634Z [4567/22] - info: [socket.io] Restricting access to origin: https://forum.mysite.dev:*
    nodebb      | Thu, 04 Apr 2019 22:33:54 GMT hsts deprecated The "includeSubdomains" parameter is deprecated. Use "includeSubDomains" (with a capital D) instead. at node_modules/helmet/index.js:33:28
    nodebb      | Thu, 04 Apr 2019 22:33:54 GMT hsts deprecated The "setIf" parameter is deprecated. Refer to the documentation to see how to set the header conditionally. at node_modules/helmet/index.js:33:28
    nodebb      | 2019-04-04T22:33:54.961Z [4567/22] - info: Routes added
    nodebb      | 2019-04-04T22:33:54.969Z [4567/22] - info: NodeBB Ready
    nodebb      | 2019-04-04T22:33:54.976Z [4567/22] - info: Enabling 'trust proxy'
    nodebb      | 2019-04-04T22:33:54.986Z [4567/22] - info: NodeBB is now listening on: 0.0.0.0:4567
    

Log in to reply
 

Suggested Topics

  • 4
  • 3
  • 2
  • 9
  • 1
| |