How to Downgrade Back to 1.11.x


  • GNU/Linux

    Hello! I'm looking into downgrading from 1.12.0 to 1.11.x, most of my plugins don't work such as Steam Authentication for the latest version which is incredibly important to me, is it safe to delete & redownload NodeBB even though my MongoDB has been on a 1.12.0 forum?

    Thank you



  • @Soarin Steam Authenticator works perfectly fine for me on 1.12
    Are you sure it's not your problem and it's the new versions problem?

    Edit: Actually it didn't work at first because of the CSRF token and the OpenID provider not providing the CSRF token upon login.
    When I get home i'll publish my fix here.


  • GNU/Linux

    That's be awesome if you published that, currently the Steam SSO v2 doesn't even show up in my plugins and the logs say it can't parse the plugin files.
    Most plugins I click to add doesn't seem to work for me, I assumed it's because 1.12.0.



  • Sorry for taking so long to reply.
    So, thing is I fixed the code on the openid passport provider manually changing a couple of lines.
    I've started looking around to see if someone did the same as I did and, someone indeed has here: https://github.com/elendirx/ignum-passport-openid
    They even added more features and fixed more things

    Now, thing is that the passport-steam should use that openid passport instead of the original one, as that one doesn't support the returnURL parameter and else (which is required for the CSRF token). So, i'm going to see if I can find a package that supports the new OpenID passport and if so, i'm going to make a new plugin for the Steam login of NodeBB and publish it on NPM.


  • GNU/Linux

    Thank you for your reply and efforts, is it normal for the Steam auth to not show up under my plugins tab or register/login? I'm not sure if it's a problem with my NodeBB installation



  • @Soarin It should appear, strange.
    Maybe you uninstalled it by accident?


  • GNU/Linux

    It's never showed up for me, I've tried all the versions on the plugin manager and they're all activated & I've restarted my forum. In the logs it just says it can't parse the plugin. 😞



  • @Soarin Can I have the exact error of the logs?


  • GNU/Linux

    @Geferon said in How to Downgrade Back to 1.11.x:

    @Soarin Can I have the exact error of the logs?

    2019-03-15T13:55:45.520Z [4567/29904] - error: Error: Cannot find module './src/emitter'
    at Function.Module._resolveFilename (internal/modules/cjs/loader.js:582:15)
    at Function.Module._load (internal/modules/cjs/loader.js:508:25)
    at Module.require (internal/modules/cjs/loader.js:637:17)
    at require (internal/modules/cjs/helpers.js:22:18)
    at Module.require.main.require (/var/www/athforum/require-main.js:8:10)
    at /var/www/athforum/node_modules/nodebb-widget-ns-stats/widget/nodebb.js:8:31
    at Object.<anonymous> (/var/www/athforum/node_modules/nodebb-widget-ns-stats/widget/nodebb.js:45:3)
    at Module._compile (internal/modules/cjs/loader.js:701:30)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:712:10)
    at Module.load (internal/modules/cjs/loader.js:600:32)
    2019-03-15T13:55:45.521Z [4567/29904] - warn: [plugins] Unable to parse library for: nodebb-widget-ns-stats
    2019-03-15T13:55:46.293Z [4567/29904] - warn: [deprecated] requiring core modules with module.parent.require('./user.js') is deprecated. Please use require.main.require("./src/<module_name>") instead.
    at /var/www/athforum/node_modules/nodebb-plugin-sso-steam-v2/library.js:4:27
    2019-03-15T13:55:46.293Z [4567/29904] - warn: [deprecated] requiring core modules with module.parent.require('../user.js') is deprecated. Please use require.main.require("./src/<module_name>") instead.
    at /var/www/athforum/node_modules/nodebb-plugin-sso-steam-v2/library.js:4:27
    2019-03-15T13:55:46.293Z [4567/29904] - error: Error: Cannot find module '../user.js'
    at Function.Module._resolveFilename (internal/modules/cjs/loader.js:582:15)
    at Function.Module._load (internal/modules/cjs/loader.js:508:25)
    at Module.require (internal/modules/cjs/loader.js:637:17)
    at Module.module.require (/var/www/athforum/src/plugins/index.js:55:26)
    at /var/www/athforum/node_modules/nodebb-plugin-sso-steam-v2/library.js:4:27
    at Object.<anonymous> (/var/www/athforum/node_modules/nodebb-plugin-sso-steam-v2/library.js:204:2)
    at Module._compile (internal/modules/cjs/loader.js:701:30)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:712:10)
    at Module.load (internal/modules/cjs/loader.js:600:32)
    at tryModuleLoad (internal/modules/cjs/loader.js:539:12)

    EDIT: I've noticed most plugins in general don't actually work for me, should I just reinstall a fresh 1.12.0 NodeBB?


  • Global Moderator

    What are the commands you used to upgrade?



  • I haven't been able to post it yet as i'm very occupied but I will when I can


Log in to reply
 

Suggested Topics

  • 1
  • 4
  • 8
  • 2
  • 18
| |