NodeBB stopped working after 'build' issued

Technical Support
  • Hi,

    I'm getting an 'internal server error' message when I try to access my NodeBB install...

    I checked out v1.11.x through Github. I followed this guide:

    My platform is FreeBSD 12.0 Release, and I have Node version 11.3 running off the Redis DB.

    What I was trying to achieve was to install the Facebook authentication plugin; it installed fine and I activated it then restarted NodeBB and then finally refreshed the browser page for the new Admin heading to come up.

    It came up fine but I couldn't access it, I just got a spinning wheel with the error: "ID text not found". After reading around I found that some people needed to issue the ./nodebb build command to get things to function. So that's what I did.

    This is the log message currently of the system:

    at eachOfLimit (/usr/local/www/NodeBB/node_modules/async/dist/async.js:1041:24)
    at /usr/local/www/NodeBB/node_modules/async/dist/async.js:1046:16
    at eachOf (/usr/local/www/NodeBB/node_modules/async/dist/async.js:1117:5)
    at _parallel (/usr/local/www/NodeBB/node_modules/async/dist/async.js:3879:5)
    at Object.parallelLimit [as parallel] (/usr/local/www/NodeBB/node_modules/async/dist/async.js:3962:5)
    at /usr/local/www/NodeBB/src/middleware/render.js:79:12
    at nextTask (/usr/local/www/NodeBB/node_modules/async/dist/async.js:5324:14)
    at next (/usr/local/www/NodeBB/node_modules/async/dist/async.js:5331:9)
    at /usr/local/www/NodeBB/node_modules/async/dist/async.js:969:16
    at /usr/local/www/NodeBB/node_modules/async/dist/async.js:473:16

    If I run the full build command the output is this:

    [benchpressjs] Unable to build or find a suitable native module, falling back to JS version
    2018-12-26T23:05:21.782Z [4567/8184] - info: [build] Building in parallel mode
    2018-12-26T23:05:21.783Z [4567/8184] - info: [build] plugin static dirs build started
    2018-12-26T23:05:21.785Z [4567/8184] - info: [build] requirejs modules build started
    2018-12-26T23:05:21.786Z [4567/8184] - info: [build] client js bundle build started
    2018-12-26T23:05:21.788Z [4567/8184] - info: [build] admin js bundle build started
    2018-12-26T23:05:21.789Z [4567/8184] - info: [build] client side styles build started
    2018-12-26T23:05:21.789Z [4567/8184] - info: [build] admin control panel styles build started
    2018-12-26T23:05:21.790Z [4567/8184] - info: [build] templates build started
    2018-12-26T23:05:21.790Z [4567/8184] - info: [build] languages build started
    2018-12-26T23:05:21.793Z [4567/8184] - info: [build] sounds build started
    2018-12-26T23:05:22.358Z [4567/8184] - info: [build] sounds build completed in 0.565sec
    2018-12-26T23:05:22.541Z [4567/8184] - info: [build] plugin static dirs build completed in 0.757sec
    2018-12-26T23:05:27.750Z [4567/8184] - error: [build] admin control panel styles build failed
    2018-12-26T23:05:27.751Z [4567/8184] - error: [build] Encountered error during build step {"meta":"Inline JavaScript is not enabled. Is it set in your options?"}
    2018-12-26T23:05:27.751Z [4567/8184] - error: Inline JavaScript is not enabled. Is it set in your options?
    [email protected]:/usr/local/www/NodeBB # events.js:167
    throw er; // Unhandled 'error' event

    Error [ERR_IPC_CHANNEL_CLOSED]: Channel closed
    at (internal/child_process.js:644:16)
    at /usr/local/www/NodeBB/src/meta/minifier.js:125:13
    at /usr/local/www/NodeBB/node_modules/async/dist/async.js:3888:9
    at /usr/local/www/NodeBB/node_modules/async/dist/async.js:473:16
    at iteratorCallback (/usr/local/www/NodeBB/node_modules/async/dist/async.js:1064:13)
    at /usr/local/www/NodeBB/node_modules/async/dist/async.js:969:16
    at /usr/local/www/NodeBB/node_modules/async/dist/async.js:3885:13
    at /usr/local/www/NodeBB/node_modules/graceful-fs/graceful-fs.js:111:16
    at /usr/local/www/NodeBB/node_modules/graceful-fs/graceful-fs.js:45:10
    at FSReqCallback.oncomplete (fs.js:148:20)
    Emitted 'error' event at:
    at process.nextTick (internal/child_process.js:648:35)
    at process.internalTickCallback (internal/process/next_tick.js:70:11)


    I'm not sure what happened or why it's doing this as I did perform an "npm install" after the install which seemed to be required? as there were things missing and other errors.

    I wonder if anyone could help a) get the forum back online and b) get the FB auth plugin functioning??

    Many thanks.

  • What instructions did you use to install?

    Have you tried disabling the plugin with ./nodebb reset -p <plugin>?

  • Hi sorry for the late response!

    I used these instructions for install:

    Yeah I did a complete uninstall / reinstall of the plugin but no change.

    Currently the site is down so I guess I'll have to remove the directory and run another git clone 😞

  • If you reinstall a broken plugin it will continue to break your forum.

Suggested Topics