Can't upgrade nodebb problem



  • Few days ago installed a nodebb instance on "test" subdomain of the url where my actual forum should reside. Today decided to run the install on the main adress too. After npm install --production I got a message that npm found 31 vulnerabilities (4 low, 25 moderate, 1 high, 1 critical). Did run npm audit fix as specified and finished after nodebb setup.

    The forum admin on the main adress gives me the warning that I have the version 1.5.3 and should upgrade to v1.10.1. Stopped nodebb did ./nodebb upgrade rebuild it, started again but I still get the message that I'm on the 1.5.3 version. Looking at the other, installed previously and I get the message that is on the version 1.5.3 too. But as far as I remember installed that one, don't know how, with the latest version back then.

    If someone could give me a little help it would be much appreciated.


  • Global Moderator

    ./nodebb upgrade doesn't actually upgrade the source files of NodeBB. Follow the instructions at https://docs.nodebb.org/configuring/upgrade/



  • @PitaJ Seend that in the meantime. After I have been through every possible error and hell discoveread that I was following the doc from readthedocs instead of the official updated one. What I just did when installing the other instance few days ago.

    Now I have the latest NodeBB installed. But after I started it had to update my Nginx config file, restarted Nginx and after the Nginx restart the Nodebb doesn't want to start anymore. I can acces my website, looks as it should but doesn't load anything( admin, topics...) and ./nodebb status gives me the response that is not started ☹ I don't know what could be wrong.



  • Problem solved. For this topic to be any usefull at all:

    • Run into first problem trying to point and click install 2 nodebb instances( test and the actual) on the same server and obviously, both couldn't listen on the same 4567 port.

    • Second, did the second install from the old docs on readthedocs instead of the official ones from nodebb.

    • Third, forgot to also add php-fpm directives to my Nginx config. And start Mongodb.


Log in to reply
 

Suggested Topics

| |