Write API plugin crashes v1.10.1 when API is called



  • I'm doing a PUT against https://myforum.com/api/v2/topics/11693/tags

    I'm trying to put the following content as application/json:

    {
      "tags": ["test1", "test2"]
    }
    

    When I do this, nodebb immediately crashes with a "callFn.apply is not a function" error message. Is the write API even compatible with v1.10.1?

    I noticed there are 2 write API plugins available. I used the one without -tmnl at the end of it. Should I be using that one instead?



  • I've also tried using CURL, and that also crashes it.

    curl --request PUT --header "Authorization: Bearer xxxxx" --header "Content-Type: application/json" --data '{"tags":"test1"}' --verbose https://myforum.com/api/v2/topics/11983/tags


  • Global Moderator

    I recommend trying other endpoints to check whether the write API is actually working.

    As for this particular one: it looks like either you're sending incorrect data or there's a bug on the backend.

    Edit: yes, you probably shouldn't be using the tmnl one



  • @Julian-H-Lam , what am I doing wrong here? Is this format correct?


 

| |