V1.4.4 to 1.9.0 - Not upgrading although saying success?



  • I have tried for a while to upgrade my NodeBB, but assumed there may have been a bug in the version levels.

    However, seeing all other members have upgraded ok, I thought I would try again.

    However, when I run ./Nodebb Upgrade, it only keeps trying to upgrade one of my plugins. Is this normal?
    The plugin is for Registration Notification. I think the actual bug lies with this plugin, as I cannot un-install it.

    -bash-4.1# ./nodebb upgrade

    1. Bringing base dependencies up to date... OK
    2. Checking installed plugins for updates... OK

    A total of 1 package(s) can be upgraded:

    • nodebb-plugin-registration-notification (1.1.0 -> 1.2.0)

    Proceed with upgrade (y|n)? y

    Upgrading packages... OK
    3. Updating NodeBB data store schema...
    4/5 17:31:05 [15876] - warn: You have no mongo password setup!
    4/5 17:31:05 [15876] - info: Beginning database schema update
    4/5 17:31:05 [15876] - info: [2016/09/22] Setting category recent tids - skipped!
    4/5 17:31:05 [15876] - info: [2016/10/8] favourite -> bookmark refactor - skipped!
    4/5 17:31:05 [15876] - info: [2016/10/14] Creating sorted sets for post replies - skipped!
    4/5 17:31:05 [15876] - info: [2016/11/22] Update global and user language keys - skipped!
    4/5 17:31:05 [15876] - info: [2016/11/25] Creating sorted sets for pinned topics - skipped!
    4/5 17:31:05 [15876] - info: [2017/2/25] Update global and user sound settings - skipped!
    4/5 17:31:05 [15876] - info: [2017/2/28] Update urls in config to /assets - skipped!
    4/5 17:31:05 [15876] - info: [upgrade] Schema already up to date!
    4/5 17:31:05 [15876] - warn: You have no mongo password setup!
    4/5 17:31:05 [15876] - info: [build] Building javascript
    4/5 17:31:05 [15876] - info: [build] Building client-side CSS
    4/5 17:31:14 [15876] - info: [build] clientCSS => Completed in 8.563s
    4/5 17:31:14 [15876] - info: [build] Building admin control panel CSS
    4/5 17:31:17 [15876] - info: [build] acpCSS => Completed in 3.17s
    4/5 17:31:17 [15876] - info: [build] Building templates
    4/5 17:31:17 [15876] - info: [build] tpl => Completed in 0.194s
    4/5 17:31:17 [15876] - info: [build] Building language files
    4/5 17:31:22 [15876] - info: [build] lang => Completed in 4.946s
    4/5 17:31:22 [15876] - info: [build] Linking sound files
    4/5 17:31:22 [15876] - info: [build] sound => Completed in 0.004s
    4/5 17:31:23 [15876] - info: [build] js => Completed in 17.753s
    4/5 17:31:23 [15876] - info: [build] Asset compilation successful. Completed in 17.813s.
    OK

                                                                          NodeBB Upgrade Complete!
    

    Although it thinks the upgrade is complete... it's not.

    If I try to manual uninstall the plugin:
    -bash-4.1# ./nodebb reset plugin="nodebb-plugin-registration-notification"
    4/5 17:42:17 [17260] - warn: You have no mongo password setup!
    /opt/MYSERVER/node_modules/mongodb/lib/mongo_client.js:236
    throw err
    ^

    Could anyone advise me if it's me doing something wrong?



  • After trying via admin panel to Upgrade, it says it goes to 1.2.0
    0_1525449452202_756e7348-b675-4ab8-b20d-85313388ab35-image.png

    If i reload my forum, it then reverts!

    0_1525449480095_64ee4cae-32e7-4916-999b-a4312555f331-image.png


  • Global Moderator

    In order to upgrade NodeBB, you have to run git fetch && git checkout v[target]

    Then you can run ./nodebb upgrade to complete the process.



  • @pitaj said in V1.4.4 to 1.9.0 - Not upgrading although saying success?:

    git fetch && git checkout v[target]


    I have ran the following and got this:
    -bash-4.1# git fetch && git checkout v[target]
    ./nodremote: Counting objects: 24606, done.
    remote: Compressing objects: 100% (35/35), done.
    remote: Total 24606 (delta 8310), reused 8327 (delta 8309), pack-reused 16262
    Receiving objects: 100% (24606/24606), 5.97 MiB | 5.15 MiB/s, done.
    Resolving deltas: 100% (19598/19598), completed with 1961 local objects.
    From https://github.com/NodeBB/NodeBB

    • [new branch] acp-alert-fix -> origin/acp-alert-fix
    • [new branch] acp-quick-actions -> origin/acp-quick-actions
    • [new branch] chat-kick-support -> origin/chat-kick-support
    • [new branch] chat-permission -> origin/chat-permission
    • [new branch] chat-rewrite -> origin/chat-rewrite
    • [new branch] data-component -> origin/data-component
      b0fa9f8..bc18b48 develop -> origin/develop
    • [new branch] fix-6404 -> origin/fix-6404
      0396e93..8e275df master -> origin/master
    • [new branch] parseInt -> origin/parseInt
    • [new branch] patch-pitaj -> origin/patch-pitaj
    • [new branch] uglify-es -> origin/uglify-es
    • [new branch] user-blocking -> origin/user-blocking
    • [new branch] v1.5.x -> origin/v1.5.x
    • [new branch] v1.6.x -> origin/v1.6.x
    • [new branch] v1.7.x -> origin/v1.7.x
    • [new branch] v1.8.x -> origin/v1.8.x
    • [new branch] v1.9.x -> origin/v1.9.x
      4713e0d..fb2f857 v1.x.x -> origin/v1.x.x
    • [new tag] v1.4.6 -> v1.4.6
    • [new tag] v1.6.1 -> v1.6.1
      From https://github.com/NodeBB/NodeBB
    • [new tag] v1.4.5 -> v1.4.5
    • [new tag] v1.5.0 -> v1.5.0
    • [new tag] v1.5.1 -> v1.5.1
    • [new tag] v1.5.2 -> v1.5.2
    • [new tag] v1.5.3 -> v1.5.3
    • [new tag] v1.6.0 -> v1.6.0
    • [new tag] v1.7.0 -> v1.7.0
    • [new tag] v1.7.1 -> v1.7.1
    • [new tag] v1.7.2 -> v1.7.2
    • [new tag] v1.7.3 -> v1.7.3
    • [new tag] v1.7.4 -> v1.7.4
    • [new tag] v1.7.5 -> v1.7.5
    • [new tag] v1.8.0 -> v1.8.0
    • [new tag] v1.8.1 -> v1.8.1
      error: pathspec 'v[target]' did not match any file(s) known to git.

    Apologies if I have done it wrong, was I supposed to enter something inside the TARGET ?

    Thanks for replying 🙂



  • I have now managed to upgrade from 1.4.0 to 1.4.6, but can't get any further.

    Plugin issue has been resolved from deleting it on filezilla

    Any ideas on going from 1.4.6 to 1.9?


 

Suggested Topics

| |