NodeBB doesn't start anymore, bugged after update

Solved Technical Support
  • Updated nodebb and I had an error with 'cwd' so I downgraded from node 9.. to 7.10.0 and now it just says that it tried 10 times and halted...

    Amazon EC2 linux

    [ec2-user@ip-172-31-41-60 nodebb]$ ./nodebb upgrade                                                                     npm WARN deprecated [email protected]: ReDoS vulnerability parsing Set-Cookie  npm WARN deprecated [email protected]: Use uuid module instead                                                            npm WARN deprecated [email protected]: connect 2.x series is deprecated                                                     npm ERR! Linux 4.9.81-35.56.amzn1.x86_64                                                                                npm ERR! argv "/home/ec2-user/.nvm/versions/node/v7.10.0/bin/node" "/home/ec2-user/.nvm/versions/node/v7.10.0/bin/npm" "install"                                                                                                                npm ERR! node v7.10.0                                                                                                   npm ERR! npm  v4.2.0                                                                                                    npm ERR! code ETARGET                                                                                                                                                                                                                           npm ERR! notarget No compatible version found: [email protected]                                                                  npm ERR! notarget Valid install targets:                                                                                npm ERR! notarget 0.2.0, 0.3.0, 0.3.1, 0.3.3, 0.3.4, 0.3.5, 0.3.6                                                       npm ERR! notarget                                                                                                       npm ERR! notarget This is most likely not a problem with npm itself.                                                    npm ERR! notarget In most cases you or one of your dependencies are requesting                                          npm ERR! notarget a package version that doesn't exist.                                                                                                                                                                                         npm ERR! Please include the following file with any support request:                                                    npm ERR!     /home/ec2-user/.npm/_logs/2018-03-28T22_45_19_646Z-debug.log                                               [email protected] /home/ec2-user/forum/nodebb/nodebb                                                                         ├── [email protected]                                                                                        └── UNMET PEER DEPENDENCY [email protected] invalid                                                                                                                                                                                npm WARN [email protected] requires a peer of nodebb-theme-vanilla@~0.0.18 but none was installed.           npm WARN [email protected] license should be a valid SPDX license expression                                                 /home/ec2-user/forum/nodebb/nodebb/public/src/utils.js:104                                                                              invalidUnicodeChars: XRegExp('[^\\p{L}\\s\\d\\-_]', 'g'),                                                                                    ^                                                                                                                                                                                                          TypeError: XRegExp is not a function                                                                                        at __dirname.undefined.module.module.exports (/home/ec2-user/forum/nodebb/nodebb/public/src/utils.js:104:24)            at Object.<anonymous> (/home/ec2-user/forum/nodebb/nodebb/public/src/utils.js:282:3)                                    at Module._compile (module.js:571:32)                                                                                   at Object.Module._extensions..js (module.js:580:10)                                                                     at Module.load (module.js:488:32)                                                                                       at tryModuleLoad (module.js:447:12)                                                                                     at Function.Module._load (module.js:439:3)                                                                              at Module.require (module.js:498:17)                                                                                    at require (internal/module.js:20:19)                                                                                   at Object.<anonymous> (/home/ec2-user/forum/nodebb/nodebb/app.js:32:10)   

    Thats what I get on upgrade

  • That is super weird. What version of NodeBB is this? And what steps did you use to install?

  • I managed to solve it, reinstalled from scratch.

Suggested Topics

  • Admin - Can't add new categories

    Solved Technical Support
    0 Votes
    2 Posts

    FYI - I checked my Digital Ocean droplet and it said that Ubuntu needs a restart. Restarted everything and have my privileges back.

  • 0 Votes
    4 Posts

    Are there any fields existing that are visible by Admin only?

  • Ban bugs

    Solved Technical Support
    0 Votes
    5 Posts

    Actually quite a nice system. Otherwise you would need to either check regularly if a ban has expired and thus probably do a lot of unnecessary checks, or you would need to predict when the next ban expiration will be and thus probably introduce a lot of bugs with the prediction code.

    What might be interesting is a feature request, to not show the flag if the expiration has happened. I assume the flag is stored with a timestamp for when the ban will expire. Thus it should be possible to filter it out when displayed. But actually remove it when the user logs in.

  • 0 Votes
    1 Posts

    My login page is (almost) entirely blank on my production server but works ok on dev and staging (heroku). I can see the home page and I can create an account and see the profile page, but I cannot login to an existing account:

    0_1458589372352_Screen Shot 2016-03-21 at 12.41.34 PM.png

    There are no javascript errors in the browser and no errors in the server side log:

    21/3 14:33 [24540] - info: NodeBB v0.9.2 Copyright (C) 2013-2014 NodeBB Inc.
    21/3 14:33 [24540] - info: This program comes with ABSOLUTELY NO WARRANTY.
    21/3 14:33 [24540] - info: This is free software, and you are welcome to redistribute it under certain conditions.
    21/3 14:33 [24540] - info:
    21/3 14:33 [24540] - info: Time: Mon Mar 21 2016 14:33:07 GMT-0500 (PET)
    21/3 14:33 [24540] - info: Initializing NodeBB v0.9.2
    21/3 14:33 [24540] - info: Environment: production
    21/3 14:33 [24540] - verbose: * using mongo store at xx.xx.xx.xx:xxxx
    21/3 14:33 [24540] - verbose: * using themes stored in: /var/www/blahblahblah/live/node_modules
    21/3 14:33 [24540] - info: [database] Checking database indices.
    21/3 14:33 [24540] - verbose: Checking dependencies for outdated modules
    21/3 14:33 [24540] - verbose: [notifications.init] Registering jobs.
    21/3 14:33 [24540] - verbose: [meta/css] Minifying LESS/CSS
    21/3 14:33 [24540] - verbose: [sounds] Sounds OK
    21/3 14:33 [24540] - verbose: [meta/templates] Compiling templates
    21/3 14:33 [24540] - verbose: [meta/templates] Successfully compiled templates.
    21/3 14:33 [24540] - verbose: [meta/css] admin.css committed to disk.
    21/3 14:33 [24540] - verbose: [meta/css] stylesheet.css committed to disk.
    21/3 14:33 [24540] - verbose: [meta/js] Minification complete
    21/3 14:33 [24540] - verbose: [hotswap] Router with id plugins replaced successfully
    21/3 14:33 [24540] - verbose: [plugins] All plugins reloaded and rerouted
    21/3 14:33 [24540] - verbose: [hotswap] Router with id auth replaced successfully
    21/3 14:33 [24540] - verbose: [meta/js] Client-side minfile committed to disk.
    21/3 14:33 [24540] - info: NodeBB Ready
    21/3 14:33 [24540] - info: Enabling 'trust proxy'
    21/3 14:33 [24540] - info: NodeBB is now listening on:

  • 0 Votes
    6 Posts

    NodeBB version: NodeBB-NodeBB-v0.6.1-0-g4686ae9