NodeBB doesn't start anymore, bugged after update

Solved Technical Support
  • Updated nodebb and I had an error with 'cwd' so I downgraded from node 9.. to 7.10.0 and now it just says that it tried 10 times and halted...

    Amazon EC2 linux

    [[email protected] nodebb]$ ./nodebb upgrade                                                                     npm WARN deprecated [email protected]: ReDoS vulnerability parsing Set-Cookie  npm WARN deprecated [email protected]: Use uuid module instead                                                            npm WARN deprecated [email protected]: connect 2.x series is deprecated                                                     npm ERR! Linux 4.9.81-35.56.amzn1.x86_64                                                                                npm ERR! argv "/home/ec2-user/.nvm/versions/node/v7.10.0/bin/node" "/home/ec2-user/.nvm/versions/node/v7.10.0/bin/npm" "install"                                                                                                                npm ERR! node v7.10.0                                                                                                   npm ERR! npm  v4.2.0                                                                                                    npm ERR! code ETARGET                                                                                                                                                                                                                           npm ERR! notarget No compatible version found: [email protected]                                                                  npm ERR! notarget Valid install targets:                                                                                npm ERR! notarget 0.2.0, 0.3.0, 0.3.1, 0.3.3, 0.3.4, 0.3.5, 0.3.6                                                       npm ERR! notarget                                                                                                       npm ERR! notarget This is most likely not a problem with npm itself.                                                    npm ERR! notarget In most cases you or one of your dependencies are requesting                                          npm ERR! notarget a package version that doesn't exist.                                                                                                                                                                                         npm ERR! Please include the following file with any support request:                                                    npm ERR!     /home/ec2-user/.npm/_logs/2018-03-28T22_45_19_646Z-debug.log                                               [email protected] /home/ec2-user/forum/nodebb/nodebb                                                                         ├── [email protected]                                                                                        └── UNMET PEER DEPENDENCY [email protected] invalid                                                                                                                                                                                npm WARN [email protected] requires a peer of [email protected]~0.0.18 but none was installed.           npm WARN [email protected] license should be a valid SPDX license expression                                                 /home/ec2-user/forum/nodebb/nodebb/public/src/utils.js:104                                                                              invalidUnicodeChars: XRegExp('[^\\p{L}\\s\\d\\-_]', 'g'),                                                                                    ^                                                                                                                                                                                                          TypeError: XRegExp is not a function                                                                                        at __dirname.undefined.module.module.exports (/home/ec2-user/forum/nodebb/nodebb/public/src/utils.js:104:24)            at Object.<anonymous> (/home/ec2-user/forum/nodebb/nodebb/public/src/utils.js:282:3)                                    at Module._compile (module.js:571:32)                                                                                   at Object.Module._extensions..js (module.js:580:10)                                                                     at Module.load (module.js:488:32)                                                                                       at tryModuleLoad (module.js:447:12)                                                                                     at Function.Module._load (module.js:439:3)                                                                              at Module.require (module.js:498:17)                                                                                    at require (internal/module.js:20:19)                                                                                   at Object.<anonymous> (/home/ec2-user/forum/nodebb/nodebb/app.js:32:10)   

    Thats what I get on upgrade

  • That is super weird. What version of NodeBB is this? And what steps did you use to install?

  • I managed to solve it, reinstalled from scratch.

Suggested Topics

  • Can NodeBB installed on a PHP server?

    Solved Technical Support
    0 Votes
    6 Posts
  • 0 Votes
    1 Posts
  • 0 Votes
    12 Posts
  • 1 Votes
    2 Posts
  • Disabling automatic updates

    Technical Support
    0 Votes
    5 Posts