Bootstrap Carousel



  • Hi guys,

    I pasted a test bootstrap carousel into the footer widget as html and everything works fine EXCEPT the arrows don't show up. This is related to Bootstrap fonts. If I include<link rel="stylesheet" href="https://maxcdn.bootstrapcdn.com/bootstrap/3.3.1/css/bootstrap.min.css"> it overrides my custom css from the admin section and the arrows work. Is there a way to get the arrows working without overriding my admin css custom settings and avaoiding external calls too because I saw that Bootstrap is included.?

    <div id="myCarousel" class="carousel slide" data-ride="carousel">
    <!-- Indicators -->
    <ol class="carousel-indicators">
    <li data-target="#myCarousel" data-slide-to="0" class="active"></li>
    <li data-target="#myCarousel" data-slide-to="1"></li>
    <li data-target="#myCarousel" data-slide-to="2"></li>
    </ol>

    <!-- Wrapper for slides -->
    <div class="carousel-inner">
    <div class="item active">
    <img src="https://images.freeimages.com/images/large-previews/39a/no-grain-no-pain-1326753.jpg" alt="Chania">
    <div class="carousel-caption">
    <h3>Los Angeles</h3>
    <p>LA is always so much fun!</p>
    </div>
    </div>

    <div class="item">
      <img src="https://images.freeimages.com/images/large-previews/310/resting-peacefully-1574880.jpg" alt="Chicago">
      <div class="carousel-caption">
        <h3>Chicago</h3>
        <p>Thank you, Chicago!</p>
      </div>
    </div>
    
    <div class="item">
      <img src="https://images.freeimages.com/images/large-previews/7e9/purple-flower-1395092.jpg" alt="New York">
      <div class="carousel-caption">
        <h3>New York</h3>
        <p>We love the Big Apple!</p>
      </div>
    </div>
    

    </div>

    <!-- Left and right controls -->
    <a class="left carousel-control" href="#myCarousel" data-slide="prev">
    <span class="glyphicon glyphicon-chevron-left"></span>
    <span class="sr-only">Previous</span>
    </a>
    <a class="right carousel-control" href="#myCarousel" data-slide="next">
    <span class="glyphicon glyphicon-chevron-right"></span>
    <span class="sr-only">Next</span>
    </a>
    </div>



  • @billygrande Self hosted, NodeBB version 1.6.1 using Vanilla theme

    Vanilla theme turned the navbar black which is why I used override to get it white again like on persona.

    Apparently when using custom css in the admin glyphfonts won't load properly.



  • Ok i see the glyphicons are there in the vanilla /less so why I aren't they working when posted in a html widget?


  • Global Moderator

    Use fontawesome icons instead of bootstrap glyphicons



  • Thanks much appreciated


Log in to reply
 


Looks like your connection to NodeBB was lost, please wait while we try to reconnect.