Error after updating config.json



  • After setting up a test Nodebb & NginX on my Mac, the url I used gave me the error "it looks like you have lost your connection to Nodebb", so I ran ./nodebb setup again to change the url. It skipped the configuration, so I manually edited the config.json file. I'm getting this error -

    /Users/iMac/NodeBB/node_modules/nconf/lib/nconf/stores/file.js:160
        throw new Error("Error parsing your configuration file: [" + this.file + ']: ' + ex.message);
        ^
    
    Error: Error parsing your configuration file: [/Users/iMac/NodeBB/config.json]: Unexpected token 
     in JSON at position 31
        at exports.File.File.loadSync (/Users/iMac/NodeBB/node_modules/nconf/lib/nconf/stores/file.js:160:11)
        at exports.Provider.Provider.add (/Users/iMac/NodeBB/node_modules/nconf/lib/nconf/provider.js:137:23)
        at exports.Provider.Provider.file (/Users/iMac/NodeBB/node_modules/nconf/lib/nconf/provider.js:63:15)
        at Object.<anonymous> (/Users/iMac/NodeBB/loader.js:14:20)
        at Module._compile (module.js:573:32)
        at Object.Module._extensions..js (module.js:582:10)
        at Module.load (module.js:490:32)
        at tryModuleLoad (module.js:449:12)
        at Function.Module._load (module.js:441:3)
        at Module.runMain (module.js:607:10)
    

    heres my config.json file

        "url": "http://my-url.ml”,
        "secret": "b95f851b-9f8a-4788-86ad-1d6bea345ac7",
        "database": "redis",
        "port": 4567,
        "redis": {
            "host": "127.0.0.1",
            "port": "6379",
            "database": "0"
        }
    }
    

    It somehow stops working when I put in the URL. When I do ./nodebb setup it does not let me change the configuration.


  • Global Moderator

    is the wrong type of quote. You should be using " instead.



  • @pitaj Oh - that's confusing. Well now it's working. Thanks.


 

| |