Can't install nodebb on Debian 8



  • Hi,

    I am trying to install nodebb on my Debian 8 server. I done npm install and when I try to do ./nodebb setup its coming error :

    /root/nodebb/node_modules/jimp/node_modules/pngjs/lib/bitpacker.js:83
    return {red, green, blue, alpha};
    ^
    SyntaxError: Unexpected token ,
    at Module._compile (module.js:439:25)
    at Object.Module._extensions..js (module.js:474:10)
    at Module.load (module.js:356:32)
    at Function.Module._load (module.js:312:12)
    at Module.require (module.js:364:17)
    at require (module.js:380:17)
    at Object.<anonymous> (/root/nodebb/node_modules/jimp/node_modules/pngjs/lib/packer.js:5:17)
    at Module._compile (module.js:456:26)
    at Object.Module._extensions..js (module.js:474:10)
    at Module.load (module.js:356:32)


  • Global Moderator

    Install nvm or n and then use one of those to install Node 6.


Log in to reply
 


Looks like your connection to NodeBB was lost, please wait while we try to reconnect.