How do I get rid of the /category/number in my URLs?

General Discussion

Suggested Topics

  • 0 Votes
    1 Posts

    Hello all,

    I am using NodeBB 1.16.2 with Oxide theme. No other plugins except the ones that came with the installation. Every time I call a page I get the following 404 message in the nginx log: - - [09/Apr/2021:10:52:02 +0000] "GET /assets/src/client/footer.js?v=4u8ga71iu38 HTTP/2.0" 404 9 "https://xxxx.xx/" "Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:87.0) Gecko/20100101 Firefox/87.0"

    I just can't find the appropriate call to it though:

    # locate footer.js /var/www/nodebb/build/public/templates/admin/footer.js /var/www/nodebb/build/public/templates/admin/partials/settings/footer.js /var/www/nodebb/build/public/templates/emails/partials/footer.js /var/www/nodebb/build/public/templates/footer.js /var/www/nodebb/install/data/footer.json /var/www/nodebb# grep -R "footer.js" ** add partials/footer/js.tpl (94da9fe5) node_modules/nodebb-theme-vanilla/templates/footer.tpl: <!-- IMPORT partials/footer/js.tpl --> node_modules/nodebb-theme-persona/templates/footer.tpl: <!-- IMPORT partials/footer/js.tpl --> src/install.js: fs.promises.readFile(path.join(__dirname, '../', 'install/data/footer.json'), 'utf8'),

    Can someone please help me or point me in the right direction? I am unfortunately a newbie in the NodeBB area. Thanks!

    Translated with (free version)

  • 1 Votes
    4 Posts

    @PitaJ @oplik0 Thank you for your reply! it helped a lot 🙂

  • 0 Votes
    2 Posts

    @sebastianneubert yeah one option is to do that. Another option is using a subdomain. Any reason why a subdomain wouldn't work for you?

  • 0 Votes
    3 Posts

    Yeah I agree at the least the bars shouldn't show up if its a link category. @psychobunny

  • 1 Votes
    13 Posts

    @baris Interesting, will disable the youtube plugin, see if that solves it.

    EDIT: Yep, youtube plugin caused it. 😆 Will need to work out why that's no longer working then. 👍 Well spotted.

    2nd EDIT: There was a random h at the end of the plugin. Embarrassing. 😆