upgrade command not working

Solved Technical Support
  • Hi,

    I have run ./nodebb upgrade in the terminal, and here's the message:

    [root@localhost nodebb]# ./nodebb upgrade
    1. Bringing base dependencies up to date... OK
    2. Checking installed plugins for updates... OK
    3. Updating NodeBB data store schema...
    23/6 05:32:41 [13464] - info: Beginning database schema update
    23/6 05:32:41 [13464] - info: [2016/09/22] Setting category recent tids - skipped!
    23/6 05:32:41 [13464] - info: [2016/10/8] favourite -> bookmark refactor - skipped!
    23/6 05:32:41 [13464] - info: [2016/10/14] Creating sorted sets for post replies - skipped!
    23/6 05:32:41 [13464] - info: [2016/11/22] Update global and user language keys - skipped!
    23/6 05:32:41 [13464] - info: [2016/11/25] Creating sorted sets for pinned topics - skipped!
    23/6 05:32:41 [13464] - info: [2017/2/25] Update global and user sound settings - skipped!
    23/6 05:32:41 [13464] - info: [2017/2/28] Update urls in config to /assets - skipped!
    23/6 05:32:41 [13464] - info: [2017/4/16] Delete sessions - skipped!
    23/6 05:32:41 [13464] - info: [upgrade] Schema already up to date!
    23/6 05:32:41 [13464] - info: [build] Building javascript
    WARN: Output exceeds 32000 characters
    WARN: Output exceeds 32000 characters
    WARN: Output exceeds 32000 characters
    WARN: Output exceeds 32000 characters
    WARN: Output exceeds 32000 characters
    23/6 05:33:00 [13464] - info: [build] js => Completed in 18.7s
    23/6 05:33:00 [13464] - info: [build] Building client-side CSS
    23/6 05:33:05 [13464] - info: [build] clientCSS => Completed in 5.448s
    23/6 05:33:05 [13464] - info: [build] Building admin control panel CSS
    23/6 05:33:09 [13464] - info: [build] acpCSS => Completed in 3.898s
    23/6 05:33:09 [13464] - info: [build] Building templates
    23/6 05:33:09 [13464] - info: [build] tpl => Completed in 0.272s
    23/6 05:33:09 [13464] - info: [build] Building language files
    23/6 05:33:14 [13464] - info: [build] lang => Completed in 4.881s
    23/6 05:33:14 [13464] - info: [build] Linking sound files
    23/6 05:33:14 [13464] - info: [build] sound => Completed in 0.005s
    23/6 05:33:14 [13464] - info: [build] Asset compilation successful. Completed in 33.313s.

                          `NodeBB Upgrade Complete!`

    It shows Upgrade Complete, but when I get back to the forum, there's nothing changed. It's still version 1.4.6. I have tried restart and reload, didn't work.
    Did I missed any process?

    Thank you,

Suggested Topics

  • Custom pages stopped working

    Unsolved Technical Support
    0 Votes
    1 Posts

    I noticed that custom pages no longer work. I see the following records in the error logs. I uninstalled and reinstalled the nodebb-custom-pages plugin. I've done several reboots and builds but it didn't work. Why might the problem be caused?
    my NodeBB version: 2.2.5
    custom pages version: 1.3.3

    2022-07-25T11:06:33.959Z [4567/1887] - error: GET /iletisim Error: Failed to lookup view "iletisim" in views directory "/home/nodes/nodebb/build/public/templates" at Function.render (/home/nodes/nodebb/node_modules/express/lib/application.js:597:17) at ServerResponse.render (/home/nodes/nodebb/node_modules/express/lib/response.js:1039:7) at /home/nodes/nodebb/src/middleware/render.js:107:11 at new Promise (<anonymous>) at renderContent (/home/nodes/nodebb/src/middleware/render.js:106:10) at renderMethod (/home/nodes/nodebb/src/middleware/render.js:75:15) at async ServerResponse.renderOverride [as render] (/home/nodes/nodebb/src/middleware/render.js:96:5)
  • 1 Votes
    25 Posts

    @patrick-sébastien-coulombe that appears to be this issue, which doesn't seem to be fixed yet.

    Strange thing in navigation urls

    Indeed under Navigation in the ACP, I can see the routes are wrong: Note that all I have done since today morning is just install the awards plugin (which d...


    NodeBB Community (community.nodebb.org)

    You should be able to fix it, at least temporarily, by modifying them manually in the ACP. Name should be [[global:header.categories]]

  • ./nodebb upgrade not works

    Technical Support
    0 Votes
    6 Posts

    @MJ said in ./nodebb upgrade not works:


    cd nodebb (or path to where nodebb is installed)
    ./nodebb stop
    git fetch
    git checkout v1.12.x
    git merge origin/v1.12.x
    ./nodebb upgrade

    after upgrade

    ./nodebb start

    I have a "one liner" that I use like this. This is what I do...

    git fetch && git checkout v1.12.x && git pull && ./nodebb stop && npm i && ./nodebb upgrade && npm i && ./nodebb start && ./nodebb log

    I put the version right at the beginning so there is just one place to change it (a script and variable would be better, but I'm lazy.) I do the NPM install manually because it used to fail. Been using the same command since the 0.6.0 days, I'd guess. And I add the log at the end so that if I look away, I always see the log scrolling to know that things are okay.

  • 0 Votes
    4 Posts

    Yeah, that nice 😉

  • 0 Votes
    8 Posts

    @flex said:

    Do you think that it's possible to don't use yours and replace it by my reverse proxy ?

    HI, If you meant that one use a niginx which is installed on a host instead of a dockerized nginx which is dedicated for NodeBB, then it's totally possible, yes 🙂

    I just put some ideas and matters

    One can remove a dockerized nginx easily by just a modifying(removing) of nginx part from docker-compose.yml. Really, that's just it. ( This is a full chain, but if one doesn't need/want a full chain then.. 🙂 ) One can use a dockerized nginx as a prime web server instead a host installed web server and can serve subomains or what ever with other docker or directory Actually this doesn't happen yet, but nginx can serve static files for NodeBB efficiently and you know, nginx is extremely small. So I'd rather proxy from a host installed nginx to the nodebb dedicated nginx docker ( In this case one needs to change a line 80:80 with 8080:80 or <any port>:80 in docker-compose.yml )

    But, if anybody wants to get an easier way and less steps, then your idea will be also a good option.