• Has anyone got this going?

    Amazon Support tell me their Linux version is close to Centos 6 so I have been following the NodeBB Installation guide by OS for Centos.
    I plan on using Mongo which is a different server in the network. NGINX is another separate server.
    I cant get past step

    After cloning the repository, obtain all of the dependencies required by NodeBB:

    when I run npm install from inside the nodebb directory I get error message

    -bash: npm: command not found

    Ive tried various sudo & yum versikons as well as running from the root but nothing works.

    Thanks in advance for any assistance.


  • @tango is npm installed? Try npm -v. If not, look up how to install Node on centos

  • Thanks @PitaJ

    I installed Node manually this way which worked perfect. Then continued with NodeBB guide & NPM install worked

    1. curl -o- https://raw.githubusercontent.com/creationix/nvm/v0.32.0/install.sh | bash
    2. Reboot machine
    3. . ~/.nvm/nvm.sh
    4. Determine what version of Node to install
    5. nvm install 6.10.3
    6. check version is installed by running
      node -e "console.log('Running Node.js ' + process.version)"

    Thank you


Suggested Topics

  • 7
  • 1
  • 1
  • 3
  • 4
| | | |