Blank Login Page



  • Hi There
    I Almost Finished My Installation But There Is A Problem
    The Login Page Is Blank!!
    So I Can't Login?Or I Can?😐



  • May be some logs be helpful.

    ./nodebb log


  • NodeBB v1.2.1 Copyright (C) 2013-2014 NodeBB Inc.
    This program comes with ABSOLUTELY NO WARRANTY.
    This is free software, and you are welcome to redistribute it under certain cond
    itions.
    For the full license, please visit: http://www.gnu.org/copyleft/gpl.html

    Clustering enabled: Spinning up 1 process(es).

    15/11 06:45 [6448] - ←[32minfo←[39m: Time: Tue Nov 15 2016 06:45:05 GMT+0330 (Ir
    an Standard Time)
    15/11 06:45 [6448] - ←[32minfo←[39m: Initializing NodeBB v1.2.1
    node_redis: Deprecated: The HMSET command contains a "undefined" argument.
    This is converted to a "undefined" string now and will return an error from v.3.
    0 on.
    Please handle this in your code to make sure everything works as you intended it
    to.
    node_redis: Deprecated: The HMSET command contains a "undefined" argument.
    This is converted to a "undefined" string now and will return an error from v.3.
    0 on.
    Please handle this in your code to make sure everything works as you intended it
    to.
    15/11 06:45 [6448] - ←[32minfo←[39m: [plugins/emoji-one] Initial startup detecte
    d. Downloading emojione assets...
    15/11 06:45 [6448] - ←[31merror←[39m: Error: connect ECONNREFUSED 10.10.34.36:44
    3
    at Object.exports._errnoException (util.js:1026:11)
    at exports._exceptionWithHostPort (util.js:1049:20)
    at TCPConnectWrap.afterConnect [as oncomplete] (net.js:1085:14)
    Error: connect ECONNREFUSED 10.10.34.36:443
    at Object.exports._errnoException (util.js:1026:11)
    at exports._exceptionWithHostPort (util.js:1049:20)
    at TCPConnectWrap.afterConnect [as oncomplete] (net.js:1085:14)
    15/11 06:45 [6448] - ←[32minfo←[39m: [app] Shutdown (SIGTERM/SIGINT) Initialised
    .
    15/11 06:45 [6448] - ←[32minfo←[39m: [app] Database connection closed.
    15/11 06:45 [6448] - ←[32minfo←[39m: [app] Web server closed to connections.
    15/11 06:45 [6448] - ←[32minfo←[39m: [app] Shutdown complete.
    [cluster] Child Process (6448) has exited (code: 1, signal: null)
    [cluster] Spinning up another process...
    15/11 06:45 [976] - ←[32minfo←[39m: Time: Tue Nov 15 2016 06:45:23 GMT+0330 (Ira
    n Standard Time)
    15/11 06:45 [976] - ←[32minfo←[39m: Initializing NodeBB v1.2.1
    15/11 06:45 [976] - ←[32minfo←[39m: NodeBB Ready
    15/11 06:45 [976] - ←[32minfo←[39m: Enabling 'trust proxy'
    15/11 06:45 [976] - ←[32minfo←[39m: NodeBB is now listening on: 0.0.0.0:4567

    So I Does Not Find Any Log Like That



  • Up..........


  • Admin

    Are you using Redis? What redis version are you using?




  • Admin

    You require at least Redis 2.8.9

    NodeBB should have warned you at start, did it not?



  • No it didn't


  • Admin

    Paste your startup log.


Log in to reply
 


Looks like your connection to NodeBB was lost, please wait while we try to reconnect.