[solved] mobile page does not work with v1.1.2

Bug Reports
  • #1

    Hi there.

    One of the most admired features of NodeBB was the great mobile page, my users loved it. Since an update to v1.1.x it no longer works correctely. The menu button is not respondand and so no user can navigate on the system. I cannot tell which upgrade broke it, but we are on v1.1.2 now.

    thanks in advance!


    I opened a github issue for this: https://github.com/NodeBB/NodeBB/issues/5026

  • #2

    Unfortunately I still have this problem.
    I set up a fresh 1.4.2 installation and only used the database of my old installation and the menu bar is still broken in the mobile view.

    Would be great if anyone has an idea or could take a look. The Page is https://community.berlinreds.de


  • Global Moderator Plugin & Theme Dev

    @spicewiesel well your websockets are broken, for starters.

    Edit: It seems like your reverse proxy config is probably the issue. Seems like certain scripts can't be loaded either.

  • #4

    @PitaJ thanks! that might be because I am on uberspace, a shared hoster. Is there a way I can check if websockets work? Then I could play with the config and check the results.

  • #5

    I don't know if this works for you, but on my nodeBB it worked a few times.

    1. admin > appearance > themes
      click on current theme and restart nodebb.

    2. admin > general > languages
      select a random langueage, restart nodebb
      than change it back.

    3. admin > appearance > skins
      click random skin, restart nodebb
      than change it back.

    one of these 3 things always worked for me 🙂 please try those and let me know if they worked.

  • Global Moderator Plugin & Theme Dev

    @spicewiesel yes you can check sockets by checking the JS console in your browser. There will be an error if the socket fails to connect.

  • #7

    Thanks @MJ, Thanks @PitaJ

    both hints helped. My nodebb did not load pages like themes/skins properly, so I tried to get websockets to work. I bypassed my shared hoster env by using an self compiled nginx on a non-privileged port and ssh tunnel (to prevent firefall changes) on that system, and that way I got websockets. Now I was able to load the theme page and so I switched to another theme, restarted and switched back to my current theme. Afterwards I stopped my temporary nginx-ws-tunnel-solution and the mobile page works for me now.

    Next step: Find a solution for a permanently working websocket setup on my hosters systems.


Suggested Topics

| | | |