Possible to login to NodeBB using telegram?

Technical Support

Suggested Topics

  • 0 Votes
    2 Posts

    Your config.json should look like this for multiple ports

    { "url": "http://example.org", "secret": "your-secret-goes-here", "database": "mongo", "port": [4567, 4568, 4569], "mongo": { "host": "", "port": "27017", "database": "0" }, "redis": { "host":"", "port":"6379", "database": 0 } }

    After ./nodebb setup modify config.json remove port from url and add the port array. Then use ./nodebb start to start nodebb. It should start up 3 nodejs processes, you can check if it worked with top

  • 0 Votes
    1 Posts

    So.... I followed the instructions using this:
    and everything seemed to go smoothly, I started the app using Heroku, and the first page I get is:
    instead of the usual homepage, and it keeps telling me this message:
    238f50e5-e4b5-440e-a06e-07157b39dc58-image.png .

    I tried reading through others who had similar issues but failed to find what is wrong with my setup, and not really sure where to start looking as i am new to this. I'd appreciate any help i can get 🙂 thanks for your time

  • 1 Votes
    9 Posts

    @scottalanmiller So unfortunately none of the versions worked with our database any more. We even tried 1.11.2 and went back to 1.10.2 on mongodb 3.2 as well.

    Now, we've updated mongodb to 3.4 and picked up an old database backup to migrate from 3.2 to 3.4 on the latest nodebb (1.11.2). Its working properly now.

    However, a warning for people on older versions of mongodb when updating to 1.11.x onward.

  • 0 Votes
    1 Posts

    Since some weeks, possibly after upgrading to 1.4.5 the modemailer causes nodebb to restart.
    Does anybody else have that problem?

    Here are the log entries:

    27/4 06:36:52 [19664] - error: TypeError: this.message.messageId is not a function at MailComposer.compile (/home/forum/nodebb/node_modules/nodemailer/node_modules/mailcomposer/lib/mailcomposer.js:90:18) at module.exports (/home/forum/nodebb/node_modules/nodemailer/node_modules/mailcomposer/lib/mailcomposer.js:7:35) at Nodemailer.<anonymous> (/home/forum/nodebb/node_modules/nodemailer/lib/nodemailer.js:286:24) at Nodemailer._processPlugins (/home/forum/nodebb/node_modules/nodemailer/lib/nodemailer.js:352:16) at Nodemailer.sendMail (/home/forum/nodebb/node_modules/nodemailer/lib/nodemailer.js:280:10) at Object.Emailer.sendViaFallback (/home/forum/nodebb/src/emailer.js:136:21) at /home/forum/nodebb/src/emailer.js:114:14 at fn (/home/forum/nodebb/node_modules/async/lib/async.js:746:34) at /home/forum/nodebb/node_modules/async/lib/async.js:1213:16 at /home/forum/nodebb/node_modules/async/lib/async.js:166:37 at /home/forum/nodebb/node_modules/async/lib/async.js:706:43 at /home/forum/nodebb/node_modules/async/lib/async.js:167:37 at Immediate.<anonymous> (/home/forum/nodebb/node_modules/async/lib/async.js:1206:34) at runCallback (timers.js:666:20) at tryOnImmediate (timers.js:639:5) at processImmediate [as _immediateCallback] (timers.js:611:5) 27/4 06:36:52 [19664] - info: [app] Shutdown (SIGTERM/SIGINT) Initialised.
  • 0 Votes
    1 Posts

    i have an error when I try to upgrade v1.1.0 to v1.1.2

    0_1470912978713_Capture d’écran 2016-08-11 à 12.55.06.png

    I am using benlulbar/nodebb docker package.

    Do you think it is an error on my database, or on the migration script code ?

    Related issue