Receive error when uploading favicon image

Technical Support

Suggested Topics

  • 1 Votes
    6 Posts

    I did a quick test to verify that nodebb setup will attempt to verify mongo access even if it has been provided - which I expected, but... and it does.

    So it seems that the best practice here would be to pass the values in as part of the build with the assumption that the Redis or mongo instance already exists.

  • 0 Votes
    4 Posts

    The common causes for a session mismatch error are usually one of the following:

    1. Mis-configured URL parameter in your config.json file

    If you have a misconfigured url value in your config.json file, the cookie may be saved incorrectly (or not at all), causing a session mismatch error. Please ensure that the link you are accessing your site with and the url defined match.

    2. Improper/malformed cookieDomain set in ACP

    Sometimes admins set this value without realising that they probably don't need to set it at all. The default is perfectly fine. This is what the config looks like:

    Cookie Domain setting

    If this is set, you'll want to revert the setting by editing your database directly:

    Redis: hdel config cookieDomain
    MongoDB: db.objects.update({ _key: "config" }, { $set: "cookieDomain": "" });

    3. Missing X-Forwarded-Proto header from nginx/apache

    If you are using a reverse proxy, you will need to have nginx pass a header through to NodeBB so it correctly determines the correct cookie secure property.

    In nginx, you will need to add the directive like so:

    location / { ... proxy_set_header X-Forwarded-Proto $scheme; ... }
  • Remove category image

    Technical Support
    0 Votes
    2 Posts

    Never mind.. when i went back into change something in the category the remove image button showed up 🙂

  • 0 Votes
    10 Posts

    @baris said:


    Great. 👍

  • Cannot GET /

    Bug Reports
    0 Votes
    6 Posts

    Not yet, still getting the same error.