Should I be concerned (install errors)?



  • In file included from ../src/bufferutil.cc:16:0:
    ../../../../nan/nan.h:328:47: error: ‘REPLACE_INVALID_UTF8’ is not a member of v8::String’
    static const unsigned kReplaceInvalidUtf8 = v8::String::REPLACE_INVALID_UTF8;
    ^
    In file included from ../src/validation.cc:15:0:
    ../../../../nan/nan.h:328:47: error: ‘REPLACE_INVALID_UTF8’ is not a member of v8::String’
    static const unsigned kReplaceInvalidUtf8 = v8::String::REPLACE_INVALID_UTF8;
    ^
    make: *** [Release/obj.target/validation/src/validation.o] Error 1
    make: Leaving directory ' /opt/nodebb/node_modules/ws/node_modules/utf-8-validate/build'
    gyp ERR! build error
    gyp ERR! stack Error: 'make' failed with exit code: 2
    gyp ERR! stack at ChildProcess.onExit (/usr/lib/node_modules/node-gyp/lib/build.js:267:23)
    gyp ERR! stack at ChildProcess.emit (events.js:98:17)
    gyp ERR! stack at Process.ChildProcess._handle.onexit (child_process.js:820:12)
    gyp ERR! System Linux 3.10.0-327.10.1.el7.x86_64
    gyp ERR! command "node" "/usr/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
    gyp ERR! cwd /opt/nodebb/node_modules/ws/node_modules/utf-8-validate
    gyp ERR! node -v v0.10.36
    gyp ERR! node-gyp -v v0.10.6
    gyp ERR! not ok
    make: *** [Release/obj.target/bufferutil/src/bufferutil.o] Error 1
    make: Leaving directory '/opt/nodebb/node_modules/ws/node_modules/bufferutil/build'
    gyp ERR! build error
    gyp ERR! stack Error: 'make' failed with exit code: 2
    gyp ERR! stack at ChildProcess.onExit (/usr/lib/node_modules/node-gyp/lib/build.js:267:23)
    gyp ERR! stack at ChildProcess.emit (events.js:98:17)
    gyp ERR! stack at Process.ChildProcess._handle.onexit (child_process.js:820:12)
    gyp ERR! System Linux 3.10.0-327.10.1.el7.x86_64
    gyp ERR! command "node" "/usr/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
    gyp ERR! cwd /opt/nodebb/node_modules/ws/node_modules/bufferutil
    gyp ERR! node -v v0.10.36
    gyp ERR! node-gyp -v v0.10.6
    gyp ERR! not ok


  • Admin

    Is this v0.9.x branch? For now perhaps you can try using master... not sure why that branch has this issue at the moment.



  • @julian said:

    Is this v0.9.x branch? For now perhaps you can try using master... not sure why that branch has this issue at the moment.

    Thanks @julian! NodeBB appears to start correctly, etc.

    I am seeing some errors with npm though. Thoughts?

    npm ERR! invalid: redis@2.4.2 /opt/nodebb/node_modules/redis
    npm ERR! extraneous: accepts@1.3.0 /opt/nodebb/node_modules/accepts
    npm ERR! extraneous: aws-sdk@2.0.5 /opt/nodebb/node_modules/aws-sdk
    npm ERR! extraneous: bindings@1.2.1 /opt/nodebb/node_modules/bindings
    npm ERR! extraneous: compressible@2.0.6 /opt/nodebb/node_modules/compressible
    npm ERR! extraneous: content-disposition@0.5.0 /opt/nodebb/node_modules/content-disposition
    npm ERR! extraneous: cookie@0.2.2 /opt/nodebb/node_modules/cookie
    npm ERR! extraneous: crc@3.3.0 /opt/nodebb/node_modules/crc
    npm ERR! extraneous: csrf@3.0.0 /opt/nodebb/node_modules/csrf
    npm ERR! extraneous: directmail@0.1.8 /opt/nodebb/node_modules/directmail
    npm ERR! extraneous: ecc-jsbn@0.1.1 /opt/nodebb/node_modules/ecc-jsbn
    npm ERR! extraneous: errno@0.1.4 /opt/nodebb/node_modules/errno
    npm ERR! extraneous: file-type@3.3.1 /opt/nodebb/node_modules/file-type
    npm ERR! extraneous: finalhandler@0.4.0 /opt/nodebb/node_modules/finalhandler
    npm ERR! extraneous: glob@5.0.15 /opt/nodebb/node_modules/glob
    npm ERR! extraneous: graceful-fs@3.0.8 /opt/nodebb/node_modules/graceful-fs
    npm ERR! extraneous: har-validator@2.0.3 /opt/nodebb/node_modules/har-validator
    npm ERR! extraneous: has-binary-data@0.1.3 /opt/nodebb/node_modules/has-binary-data
    npm ERR! extraneous: heapdump@0.3.7 /opt/nodebb/node_modules/heapdump
    npm ERR! extraneous: image-size@0.3.5 /opt/nodebb/node_modules/image-size
    npm ERR! extraneous: jodid25519@1.0.2 /opt/nodebb/node_modules/jodid25519
    npm ERR! extraneous: merge-descriptors@1.0.0 /opt/nodebb/node_modules/merge-descriptors
    npm ERR! extraneous: methods@1.1.1 /opt/nodebb/node_modules/methods
    npm ERR! extraneous: nan@2.1.0 /opt/nodebb/node_modules/nan
    npm ERR! extraneous: parseuri@0.0.2 /opt/nodebb/node_modules/parseuri
    npm ERR! extraneous: promise@6.1.0 /opt/nodebb/node_modules/promise
    npm ERR! extraneous: pseudomap@1.0.1 /opt/nodebb/node_modules/pseudomap
    npm ERR! extraneous: public-address@0.1.1 /opt/nodebb/node_modules/public-address
    npm ERR! extraneous: qs@5.2.0 /opt/nodebb/node_modules/qs
    npm ERR! extraneous: serve-static@1.10.0 /opt/nodebb/node_modules/serve-static
    npm ERR! extraneous: source-map@0.4.4 /opt/nodebb/node_modules/source-map
    npm ERR! extraneous: to-array@0.1.3 /opt/nodebb/node_modules/to-array
    npm ERR! extraneous: tweetnacl@0.13.2 /opt/nodebb/node_modules/tweetnacl
    npm ERR! extraneous: xml@1.0.0 /opt/nodebb/node_modules/xml
    npm ERR! extraneous: engine.io@1.5.4 /opt/nodebb/node_modules/engine.io
    npm ERR! extraneous: engine.io-client@1.5.4 /opt/nodebb/node_modules/engine.io-client
    npm ERR! extraneous: mailcomposer@0.2.12 /opt/nodebb/node_modules/mailcomposer
    npm ERR! extraneous: socket.io-parser@2.2.4 /opt/nodebb/node_modules/socket.io-parser
    npm ERR! extraneous: socket.io-adapter@0.3.1 /opt/nodebb/node_modules/socket.io-adapter
    npm ERR! extraneous: npm@2.14.15 /opt/nodebb/node_modules/npm
    npm ERR! not ok code 0



  • Anyone have any ideas? @julian



  • Not an expert but you can try to run npm install with an option --save.



  • @nhl.pl said:

    Not an expert but you can try to run npm install with an option --save.

    Thanks, but the errors persist.


Log in to reply
 


Looks like your connection to NodeBB was lost, please wait while we try to reconnect.