v0.9.3: Nodebb not displaying certain text but showing the "variables" instead

Solved Technical Support
  • I am reporting an odd behavioral problem. I logged into my Nodebb forum which has two-factor authentication enabled for my acount. Upon logging in with my user/pass combination I was then presented with my two-factor screen. I noticed that the two-factor page was not displaying the actual text that should be there but rather just the "variables" of what the text should say. I ignored the problem with my mind passing it off as a Google two-factor glitch. The actual two-factor login did work fine.

    Fast forward 30 minutes and I have run into the same scenario. I just installed the user invitation plugin, nodebb-plugin-newuser-invitation. I "reloaded" the forum and then went to the plugin settings. Here too I am not seeing the actual text of the plugin (as shown at the plugin's github page) but rather these short cut codes. I thought maybe a reload wasn't sufficient and did a "restart" of Nodebb. After the restart the same problem presented itself. Still thinking this is a server problem I went ahead and rebooted the actual Linux server. After the server reboot and then start up of Nodebb I again am seeing this problem. This is a screenshot of it:


    Does anyone have an idea of what is going wrong?

    Thank you.

  • Just to rule out a bad update. Try the following

    Git pull
    Npm update
    ./nodebb upgrade
  • @a_5mith I've been running this version of 0.9.3 for about a month. I am leary about doing an upgrade as I don't want to go to "master / 1.0.0" until I know if my setup and plugins will work with it.

  • Git pull should pull whatever branch you're currently on. So unless you're on master. It will just pull 0.9.x again.

    You can verify what branch you're on with Git status I think. On my phone so that could be wrong. Can't check it. 🙂

  • @a_5mith What is your opinion on this:

    $ git status
    # On branch v0.9.x
    # Untracked files:
    #   (use "git add <file>..." to include in what will be committed)
    #       S3EnvironmentSettings

    The S3EnvironmentSettings file is where I save my amazon-s3 plugin settings. I source this file before I start this instance of Nodebb

    So all looked good so far. I did this:

    [edit out stuff.. let me see if this posts]

    Shoot.. now this site won't take this post "as-is" Akismet is flagging it as spam. Let me see what I can edit out

  • @rod And now for more:

    $ git pull
    remote: Counting objects: 2799, done.
    remote: Compressing objects: 100% (104/104), done.
    remote: Total 2799 (delta 1897), reused 1854 (delta 1854), pack-reused 841
    Receiving objects: 100% (2799/2799), 941.63 KiB | 0 bytes/s, done.
    Resolving deltas: 100% (2324/2324), completed with 610 local objects.
    From https://github.com/NodeBB/NodeBB
       9f14e8e..cf5decf  v0.9.x     -> origin/v0.9.x
       80fd0b2..c8d741a  master     -> origin/master
    Updating 9f14e8e..cf5decf
    [edit out list of things.. will Akismet take it now?]

    Did I just update to master? Should that have happened?

    I have not done anything else at this point.

  • @rod Let's see if Akismet takes the following, which is what I cut out of the previous post:

    NO. Akismet does not like me. 😞

    Screenshot time:

    So, with all of that posted (sorry about the cut-ups), is it safe to proceed and stay on 0.9.3?

  • @rod what's the output of git rev-parse HEAD

  • @pichalite

    $ git rev-parse HEAD
  • @rod there is nothing to worry... you are still on v0.9.x branch.

    You would have got a lot more files when you ran git pull if it was master

  • @pichalite Alright thanks. Let me continue on with @a_5mith suggestion of:

    Git pull
    Npm update
    ./nodebb upgrade
  • The "upgrade" (to the same version, 0.9.3) completed. After starting Nodebb up I am getting the same issues. Two-factor and the new user invitiation plugin are not showing the text.

    This time I logged in while I still had ./nodebb log running on my console. Upon the two-factor page loading I saw this error displayed in the console:

    8/2 10:52 [3466] - error: [translator] Could not load `2factor`: ENOENT, open '/home/centos/nodebb_installation/[myForumNameDirectory]/public/language/en_US/2factor.json'. Skipping...
    Redacted this directory as it shows my forum name and am using this as a place holder for this post "[myForumNameDirectory]"
  • I solved my problem.

    Well, sort of. I changed my user language, in my profile from en_US back to en_GB.

    Now my two-factor and user invitation plugin display properly.

    But, why did my user profile language change? I do not recall changing it. Maybe I did at some point and I just do not recall. The last plugin I installed prior to today was the nodebb-plugin-newsletter to test it for the developer, in another thread.

    I un-installed that plugin and it did not make a difference but that is when I noticed my user profile language was set to en_US.

Suggested Topics