Instalation stuck on "Pupolating Database..."

Technical Support
  • Hi !!

    i just tryed to install nodeBB on my VPS, but stuck on this possition:

    alt text

    Can anyone help me with this ? Thanks !!

  • Hi there, please let me know the output of lsb_release -a and uname -a please.

  • @julian said:

    lsb_release -a

    This iss output:

    root@the [~]# lsb_release -a
    -bash: lsb_release: command not found


    root@the [~]# uname -a
    Linux 2.6.32-042stab113.11 #1 SMP Fri Dec 18 17:32:04 MSK 2015 x86_64 x86_64 x86_64 GNU/Linux

    Also im geting this when run this command:

    root@the [~/public_html]# sudo service redis start
    Starting redis-server:
    Reading the configuration file, at line 53
    'logfile /var/log/redis/redis.log'
    Can't open the log file: Permission denied

    root@the [~/public_html]# sudo service redis status
    redis-server is stopped

    How to reenable redis server again?

    NOTE: I reenabled radis again>

    root@the [/]# sudo service redis status
    redis-server (pid 4183) is running...

    added firewall rules:

    firewall --zone=public --add-port=4567/tcp --permanent
    firewall --reload

    and start nodebb from

    ./nodebb start

    but still not open on


  • For best results, I'd recommend using Ubuntu 14.04, as that is the OS we test on. It doesn't look like you're using Ubuntu.

    Secondly, your redis server isn't starting, so you'll need to resolve that before continuing with NodeBB setup.

  • I started Redis server with "sudo service redis start" but still not open me nothing. I think that issue is somewhere in firewall.

    Do you noticed what i write before:

    root@the [/]# sudo service redis status
    redis-server (pid 4183) is running...

    So radis server is working !!

  • @MagicVish No, no. For the field Which database to use do not enter redis but enter 0. You already chose redis earlier in the setup. This field instructs NodeBB which redis database to populate and use. The databases start at 0 and increase incrementally. If this is your first and only redis database 0 is the answer.

Suggested Topics