[nodebb-plugin-emoji-extended] Emoji Extended


  • Plugin & Theme Dev

    Completely forgot to publish it here ^^

    It's a fork of the well-known emoji-plugin that adds some mappings like ;) to :wink: etc.
    Runs with less priority than emoji-skype-plugin.

    Also it excludes the code-blocks, which isn't implemented in current version of emoji.

    Here you go

    Deprecated Installation (you should rather install via NodeBB Admin-CP):

    npm install nodebb-plugin-emoji-extended
    

    Note: This is a standalone plugin, having it enabled besides nodebb-plugin-emoji will cause parsing-conflicts!


  • Admin

    Excellent, @frissdiegurke, cheers! I'll enable it here.

    I'm a fan of Skype Emoji (hence why it's the second NodeBB plugin ever created), but for the purposes of cohesive emoticon sets, I may just give emoji-extended a shot instead of emoji+emoji-skype.



  • @julian skype emoji > *


  • Admin

    @Chris haha.. no more (mooning) (poolparty) for you... have to live with 👿 :neckbeard:


  • Plugin & Theme Dev

    @julian Therefor you'll be able to use autocompletion soon... nearly finished 😉


  • Admin

    @frissdiegurke Are you using textcomplete? Please be advised that you should use the new functionality exposed here: https://github.com/yuku-t/jquery-textcomplete/issues/43



  • @julian :@


  • Admin

    On the up-side, I believe the plugins are compatible with each other, but emoji-extended gracefully lets Skype emoticons take preference. Need a way to specify the priority via admin panel config 🙂


  • Plugin & Theme Dev

    This could be solved also by enabling/disabling the mapping and taking the higher (less than skypes) priority 😉 that's possible, will take a look at


  • Plugin & Theme Dev

    @julian said:

    Are you using textcomplete? Please be advised that you should use the new functionality exposed here: https://github.com/yuku-t/jquery-textcomplete/issues/43

    As far as I can see either he didn't fix the bug yet or the old verion of the mentions-plugin blocks the fix...
    But it doesn't matter if there are mutiple wrappers as long as you don't append the same strategy multiple times.

    I solved this now as following:

    $('body').on 'focus', '.composer .title, .composer .write', ->
      composer = $('.composer .write')
      return if composer.data 'emoji-extended-added'
      composer.data 'emoji-extended-added', 'true'
      [...]
    

    So it's guaranteed that [...] gets called only once per composer. I need to decrease the filter:scripts.get-priority below mentions as long as the problem doesn't get fixed there 😉


  • Admin

    Mentions should get the fix. I might take a look at it myself tomorrow.

    The main thing I don't like is that both mentions and emoji-extended will be loaded an identical textcomplete library, but there's not much you can do about that, I think...


  • Plugin & Theme Dev

    @frissdiegurke said:

    As far as I can see either he didn't fix the bug yet or the old verion of the mentions-plugin blocks the fix...

    Damn, my fault... wrong path => 404 ^^

    Ok, new version is online. According to the spelling-mistake within my previous posts it's time to sleep zzz

    A short question you may answer in the meantime: How can I set admin-configuration defaults? I'd like to have the 'Enable Mapping' config to be '1' by default and the appropriate checkbox should be checked.

    Maybe a second question: How can I persist config-changes without restart the server? (If nobody answers this I neeed to lookup the markdown-plugin tomorrow...)


  • Admin

    1. You can use Meta.configs.setOnEmpty to set config values. Run that method for each value you'd like to set in a method that listens for the action:plugin.activate hook. That hook sends the plugin id.
    2. If you're using Settings.prepare to save changes in the ACP, they automatically persist, no server restart required (though you'll have to ensure that your code is not caching the value in Meta.config

  • Plugin & Theme Dev

    @julian Thanks, implemented. works great :I_dont_know_the_text_for_thumbs_up_smiley_please_install_the_new_version_of_my_plugin: 😉


  • Admin

    LOL! Can you do it for regular emoji too? Much obliged 😄

    (p.s. Mentions plugins has been updated to use the new textcomplete version too)

    👍 Works great! 😸


  • Plugin & Theme Dev

    @julian said:

    LOL! Can you do it for regular emoji too? Much obliged 😄

    (p.s. Mentions plugins has been updated to use the new textcomplete version too)

    👍 Works great! 😸

    didn't test it with :+1: ^^

    seems like encoded ULIs get filtered to 404 o_O I guess this needs to be fixed within core...

    and one other issue with :+1: I'll need to fix is that the regex doesn't match any more after typing :+ 😉

    With "regular emoji" you mean the plugin right? Not :), etc. In the first case I'd say the plugin may be taken down and I could remove the 'extended', because the reason for two different plugins has been the mapping of common smileys that now can be removed via settings. In the second case I think it's a bit overheaded because the dropdown would to often.


  • Plugin & Theme Dev

    seems like encoded ULIs get filtered to 404 o_O I guess this needs to be fixed within core...

    Opened Issue


  • Admin

    @frissdiegurke Take a look at this autofill.js:

    https://github.com/julianlam/nodebb-plugin-mentions/blob/df358c2924f7dc1417c29acc4c1df5dfe8749b3d/static/autofill.js#L2

    I'm listening for the client-side event action:composer.loaded, which is better than adding a new textcomplete onfocus


  • Admin

    I'm thinking of bundling emoji-extended with all new NodeBB installs... :shipit:

    Two issues however:

    • Emoji autocomplete does not seem to work when editing a post (my post before this one might help with that)
    • Typing : triggers autocomplete even at the end of words (perhaps it should check for a word boundary)
      • It also means autocomplete triggers when I am typing the end of another emoji: :shipit: <-- autocomplete triggers

  • Plugin & Theme Dev

    @julian First issue should be fixed already since I've used your solution like 10min after your post 😛 .
    Second issue already noticed, will be fixed soon...

    👍 (if there would be no 404 Error on this) to bundling 😉

    New issue figured out writing this post: some mappings (just some because of other reasons) need \s|$ after key, so I can't write sth. like :P. ^^


Log in to reply
 

Suggested Topics

| |