i can not install nodebb

NodeBB Development
  • root@ubuntu:/opt/nodebb/nodebb# apt-get install git nodejs redis-server npm build-essential imagemagick
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    git is already the newest version.
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    The following packages have unmet dependencies:
     nodejs : Conflicts: npm
    E: Unable to correct problems, you have held broken packages
  • As I understand it, installing nodejs pulls in npm, so there's no need to install npm separately.

    Your command should read apt-get install nodejs redis-server build-essential imagemagick. The system said you have git installed already, so no need to have it in the command.

  • Ah yes, funny that. Perhaps we started NodeBB before npm made it into core? Let me remove it from the readme now.

  • 嗨哥们我相信你能看懂。。最近我开始学习nodejs研究nodebb
    and..i cannot install nodebb as well
    error: cannot find module nconf

  • @sunqi did you run npm install? and if so did you run into any errors

  • @psychobunny oh thanks..i run npm install already and run node app,
    info: This looks like a new installation, so you'll have to answer a few q
    ns about your environment before we can proceed.

    info: Press enter to accept the default setting (shown in brackets).
    URL of this installation (http://localhost) http://sunqi
    Port number of your NodeBB (4567)
    Use a port number to access NodeBB? (y)
    IP or Hostname to bind to (
    Which database to use (redis)
    Host IP or address of your Redis instance (
    Host port of your Redis instance (6379)
    Password of your Redis database 12345678
    Which database to use (0..n) (0)
    info: Configuration Saved OK
    info: Populating database with default configs, if not already set...
    error: Redis connection to failed - connect ECONNREFUSED
    warn: NodeBB Setup Aborted.

    hope u can help me ,i'm a green hand

  • @sunqi Looks like your redis instance is not running.

    Can you access it when you run redis-cli from the command line?

  • seems that i should read the README first....and the new problem is that how can i run the command:

    # apt-get install git nodejs redis-server build-essential imagemagick
  • Just copy and paste that into your terminal 🙂 that is if you're running on a unix or unix-like system (Ubuntu, mint, centos etc.) if on a Mac, you have to install those packages with brew.

  • @BDHarrington7 thx
    but i use windows..in fact i'm a pc user instead of developer= =!

  • In that case, install GitHub for windows, Node.js (from website), Redis (from website), and that should be enough... I think...

Suggested Topics

  • 6 Votes
    3 Posts

    @arutemu Link. Nodebb supported Nodejs 8. I install Nodejs 8 for NodeBB and Ghost, this is working and look good!

  • Nodebb v1.3.0

    NodeBB Development
    3 Votes
    1 Posts

    NodeBB team release v1.3.0.

    Thats new:

    Add to post "replies to this post" link (expands/collapses the replies inline under the post) SSO plugins can to redirect users back to the page they were on User is able to restore deleted posts EU Cookies Notification/Warning Show original post/topic etc dates older than month (customizable) add registration queue approvals/rejections to the event log fix collision of button text in user picture changer on mobile/tablet devices refactor favourites (favourites become bookmarks) breaking change plugins and themes edit password screen can display validations default group chat name to usernames automatically deleting the topic with no posts (when moderator delete last undeleted post) allow regular moderators to access the general flagging interface textcomplete update to 1.7.2

    Мore: https://github.com/NodeBB/NodeBB/milestone/48?closed=1

  • 0 Votes
    2 Posts

    I git clone v1.x.x branch.
    today I git reset --hard fdd8514, then work OK!

  • 2 Votes
    34 Posts

    Use pgrep/pkill! 😉

    kill -s USR1 $(fgrep -f "app.js")

    or even shorter with pkill

    pkill -USR1 -f "app.js"

    Substitute -USR1 with -SIGHUP and you got yourself a quick and easy build-tool command to restart NodeBB, when changing files. 🙂
    (I'm using SublimeText / Atom)

  • Subfolder installation

    NodeBB Development
    1 Votes
    11 Posts


    I've you been able to get this to work in production? Mine's not working.