Issues trying to setup NodeBB with MongoDB on DigitalOcean[solved]



  • Hello!

    So I've been trying to setup NodeBB on a DO droplet (Ubuntu 14.04) with mongodb -- and I think some of the documentation might be outdated.

    Regardless of which during the nodebb setup I'm getting errors about a "double colon in host identifier" -- if I try to change a few things I get "connect ECONNREFUSED"

    And due to various tutorials, I've confused myself more than I'd like to admit.

    Is there an official up to date documented guide to installing NodeBB?



  • In case anyone is curious and is having the same issues that I was having, I decided (and found out how to use) the web installer.

    Once you've cloned your copy of the repo of NodeBB and snatched your dependencies -- go to your directory that you've copied the repo to.

    use: "ls -la" to make sure you can see the "loader.js" file -- now what you're gonna want to do is use "nodejs loader.js" (we use nodejs because ubuntu has conflicts and needs to use nodejs to avoid said conflicts).

    The first time I ran the web installer it did not like my personal inputs for the db name and password and even name of the database - so for the 2nd time, after I selected to use "MongoDB" for the database, I left the rest blank.

    This worked.

    Hope this helps any others!

    p.s. -- if anyone knows readily where the mongodb database files are being stored for nodebb, that'd be helpful!


  • GNU/Linux

    You prob should have a read in this https://docs.mongodb.org/manual/tutorial/enable-authentication/

    login to mongo > show dbs



  • @Joykiller did read it, didn't help, and couldn't get it to work. Not saying it's wrong, saying I didn't understand it lol.


  • GNU/Linux

    @ZenOokami

    Step 6: Adding a New Database With Users
    To go into the MongoDB command line, type:

    $ mongo
    To add a new database called nodebb, type:

    use nodebb
    To add a user to access the nodebb database, type:

    For MongoDB 2.6.x

    db.createUser( { user: "nodebb", pwd: "<Enter in a secure password>", roles: [ "readWrite" ] } )

    Copypasta from doc's. then once you install it using that db/user/pw - go into mongo and type: show dbs

    Then you will see the database used for nodebb you setup and modify values using use nameofdb

    So far thats all I know, I started using nodebb like yesterday (well a few days ago), Mongo at same time.



  • I don't think it was Mongodb's user or db being the issue ._.
    Pretty sure "host identifier" has something to do with either nodebb or mongo's hosting setup, but I think it was that of NodeBB

    on the second time it wasn't accepting my webInstaller settings - not through the command line.

    But thanks.


  • GNU/Linux

    @ZenOokami said:

    I don't think it was Mongodb's user or db being the issue ._.
    Pretty sure "host identifier" has something to do with either nodebb or mongo's hosting setup, but I think it was that of NodeBB

    on the second time it wasn't accepting my webInstaller settings - not through the command line.

    But thanks.

    I wasn't talking about host identifier, I was talking about how to set up using auth and managing your DB's.

    You having connection issues you should post all your logs, including nodebb, nginx configurations etc.

    You said:

    double colon in host identifier

    Most likely issue with having a wrong syntax with the config.


Log in to reply
 


Looks like your connection to NodeBB was lost, please wait while we try to reconnect.