NPM Timing Out on NodeBB dependencies install

Technical Support
  • #1


    I'm running into a problem where NPM seems to time out when installing dependencies for NodeBB. It happens when installing NodeBB both from NPM or after running npm install from a git clone. It's not my network as I'm able to install other node packages through NPM just fine. It's strange because earlier this week I was able to install NodeBB fine. I removed it because i wanted to do a fresh install to test something.

    Here is a snippet from the npm install log when things start going weird:

    23739 silly gunzTarPerm extractEntry emoji/yen.png
    23740 silly gunzTarPerm extractEntry emoji/yum.png
    23741 silly gunzTarPerm extractEntry emoji/zap.png
    23742 silly gunzTarPerm extractEntry emoji/zero.png
    23743 silly gunzTarPerm extractEntry emoji/zzz.png
    23744 silly gunzTarPerm extractEntry client-scripts/emoji-textcomplete.js
    23745 silly gunzTarPerm extractEntry plugin.json
    23746 silly gunzTarPerm extractEntry styles/style.less
    23747 silly gunzTarPerm extractEntry templates/admin/plugins/emoji-extended.tpl
    23748 silly cache afterAdd [email protected]
    23749 verbose afterAdd /Users/will/.npm/nodebb-plugin-emoji-extended/0.4.17/package/package.json not in flight; writing
    23750 verbose afterAdd /Users/will/.npm/nodebb-plugin-emoji-extended/0.4.17/package/package.json written
    23751 info retry will retry, error on last attempt: Error: read ETIMEDOUT
    23752 info attempt registry request try #2 at 9:00:13 PM
    23753 http fetch GET
    23754 info retry will retry, error on last attempt: Error: read ETIMEDOUT
    23755 verbose stack Error: read ECONNRESET
    23755 verbose stack at exports._errnoException (util.js:860:11)
    23755 verbose stack at TLSWrap.onread (net.js:544:26)
    23756 verbose cwd /Applications/MAMP/htdocs/NodeBB
    23757 error Darwin 15.2.0
    23758 error argv "/usr/local/Cellar/node/5.0.0/bin/node" "/usr/local/bin/npm" "install"
    23759 error node v5.0.0
    23760 error npm v3.3.9
    23761 error code ECONNRESET
    23762 error errno ECONNRESET
    23763 error syscall read
    23764 error network read ECONNRESET
    23764 error network This is most likely not a problem with npm itself
    23764 error network and is related to network connectivity.
    23764 error network In most cases you are behind a proxy or have bad network settings.
    23764 error network
    23764 error network If you are behind a proxy, please make sure that the
    23764 error network 'proxy' config is set properly. See: 'npm help config'
    23765 verbose exit [ 1, true ]

    I've tried removing node completely and reinstalling it. I'm out of ideas to try. Posting here to see if this happens to anyone else.

    Edit: running on Mac OS X 10.11.2

  • #2

    I've been doing some messing around and thought I'd share what I've discovered here, in case it can help.

    I've been doing all kinds of uninstalling and re-installing of various programs, and am now running node from the base installation from rather then through brew package manager. Although I don't think that has anything to do with the error i was running into as I still run into this error under a certain condition.

    So when I first installed nodebb, I've realized that was the master github branch, and npm install runs just fine on it. So after that I decided to branch v0.9.x again and see if npm install worked, and it did not work. Same kind of timed out errors as above. So after that i went ahead and branched v0.9.2 and npm install works on v0.9.2.

    So, this error seems to be directly related to the latest v0.9.x branch. I tried upgrading my 0.9.2 nodebb version up to the v0.9.x branch, and i can't, it gets stuck on this step:
    1. Bringing base dependencies up to date...

    I also created a test directory for v0.9.x and tried replacing its package.json with the package.json of the master build just to see if it could bypass the time out errors. I know doing that isn't recommended as it could possibly break the software overall, just wanted to see if it could pass the timed out errors, but it still didn't.

  • GNU/Linux

    I was having some issues with NPM a few days ago which was timing out, but was a issue with ports due to my firewall setup. So check to make sure git port is not being blocked.

    Also could be an issue with the way your cloning. Was having issues cloning from another git like gitlab vs github, turns out the git:// git:link was the issue try adding that to the front if using SSH cloning.

Suggested Topics

| | | |