Error: Cannot find module './Categories' linux?

Moved Technical Support

Suggested Topics


  • 0 Votes
    6 Posts
    447 Views

    sorry this problem is solved the problem was the local firewall ☠

  • 0 Votes
    2 Posts
    286 Views

    Hi there, what errors do you see in server-side?

  • 0 Votes
    2 Posts
    965 Views

    @h7 tried on a different Debian 7 (Wheezy) server, to make sure this is a common issue:

    Node.js v4.2.2 Redis server v=3.2.11 NodeBB v1.0.3

    NodeBB installs again, without errors but the log comes back with the exact same [2458] - error: undefined

    npm rm nodebb-plugin-emoji-one npm install [email protected]

    fixed that error, now:

    info: Time: Sun Oct 08 2017 04:59:32 GMT+0300 (MSK) info: Initializing NodeBB v1.0.3 [outdated] nodebb-plugin-emoji-one installed v1.1.4, package.json requires 1.1.0 warn: One or more of NodeBB's dependent packages are out-of-date. Please run the following command to update them: warn: ./nodebb upgrade [cluster] Child Process (6503) has exited (code: 0, signal: null)

    OK, removing the plugin npm rm nodebb-plugin-emoji-one and ./nodebb start worked, NodeBB v1.0.3 running, still can't log-in:

    warn: [meta/dependencies] Bundled plugin nodebb-plugin-emoji-one not found, skipping dependency check. [minifier] file not found, node_modules/socket.io-client/socket.io.js [minifier] file not found, node_modules/socket.io-client/socket.io.js info: NodeBB Ready info: Enabling 'trust proxy' info: NodeBB is now listening on: 0.0.0.0:4567 error: /login invalid csrf token error: /login invalid csrf token

    using older versions of socket.io:

    npm remove socket.io npm remove socket.io-client npm install [email protected] npm install [email protected]

    did the trick, NodeBB v1.0.3 running and ready for myBB to NodeBB transition

  • 0 Votes
    8 Posts
    3k Views

    restarted a few times again nodebb working now thanks 😄

  • Missing icons / broken CSS

    Unsolved Technical Support
    0 Votes
    9 Posts
    2k Views

    @paviro said in Missing icons / broken CSS:

    How is it that only some of the default skins actually work? 😕

    Obviously not all skins are tested with persona.