Getting error during installation

  • GNU/Linux Admin

    What Node.js version are you using?


  • ngsankar@TestM:~$ node --version
    v0.12.7

    I didnt install this version specifically. As part of the installation instruction, I believe the latest stable version gets installed.


  • If I would be you I would reinstall Node and all its components:

    apt-get remove node*
    apt-get purge node*

    And maybe this as well:

    Then check after your repos and maybe remove any additional ones related to NodeJS and run:
    apt-get update
    apt-get install nodejs nodejs-legacy npm

    Verfiy the versions by running node -v and node-gyp -v.


    1. took a snapshot of the droplet.
    2. removed node and reinstalled as suggested.
    3. Same node version and ended up same error..

  • @gvimlan, @BDHarrington7 , were you able to get this resolved ?

  • Community Rep

    I haven't had a chance yet.


  • Same error. No changes 😞

  • GNU/Linux

    I'm having a similar error while trying to install NodeBB with Mongo.

    Here's the full log:

    Welcome to NodeBB!
    
    This looks like a new installation, so youll have to answer a few questions about your environment before we can proceed.
    Press enter to accept the default setting (shown in brackets).
    
    8/11 20:06 [10508] - info: Now configuring mongo database:
    Configuration Saved OK
    npm WARN peerDependencies The peer dependency kerberos@~0.0 included from mongodb-core will no
    npm WARN peerDependencies longer be automatically installed to fulfill the peerDependency 
    npm WARN peerDependencies in npm 3+. Your application will need to depend on it explicitly.
    
    > kerberos@0.0.17 install /home/mboisvert/Documents/nodemongo/node_modules/mongodb/node_modules/kerberos
    > (node-gyp rebuild) || (exit 0)
    
    make: Entering directory '/home/mboisvert/Documents/nodemongo/node_modules/mongodb/node_modules/kerberos/build'
      CXX(target) Release/obj.target/kerberos/lib/kerberos.o
    In file included from ../lib/kerberos.cc:1:0:
    ../lib/kerberos.h:5:27: fatal error: gssapi/gssapi.h: No such file or directory
    compilation terminated.
    kerberos.target.mk:94: recipe for target 'Release/obj.target/kerberos/lib/kerberos.o' failed
    make: *** [Release/obj.target/kerberos/lib/kerberos.o] Error 1
    make: Leaving directory '/home/mboisvert/Documents/nodemongo/node_modules/mongodb/node_modules/kerberos/build'
    gyp ERR! build error 
    gyp ERR! stack Error: `make` failed with exit code: 2
    gyp ERR! stack     at ChildProcess.onExit (/home/mboisvert/Documents/nodemongo/node_modules/npm/node_modules/node-gyp/lib/build.js:270:23)
    gyp ERR! stack     at emitTwo (events.js:87:13)
    gyp ERR! stack     at ChildProcess.emit (events.js:172:7)
    gyp ERR! stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:200:12)
    gyp ERR! System Linux 4.2.5-300.fc23.x86_64
    gyp ERR! command "/usr/local/bin/node" "/home/mboisvert/Documents/nodemongo/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
    gyp ERR! cwd /home/mboisvert/Documents/nodemongo/node_modules/mongodb/node_modules/kerberos
    gyp ERR! node -v v5.0.0
    gyp ERR! node-gyp -v v3.0.3
    gyp ERR! not ok 
    npm WARN unmet dependency /home/mboisvert/Documents/nodemongo/node_modules/jade requires mkdirp@'0.3.0' but will load
    npm WARN unmet dependency /home/mboisvert/Documents/nodemongo/node_modules/mkdirp,
    npm WARN unmet dependency which is version 0.5.1
    npm WARN unmet dependency /home/mboisvert/Documents/nodemongo/node_modules/grunt requires async@'~0.1.22' but will load
    npm WARN unmet dependency /home/mboisvert/Documents/nodemongo/node_modules/async,
    npm WARN unmet dependency which is version 1.4.2
    npm WARN unmet dependency /home/mboisvert/Documents/nodemongo/node_modules/grunt requires colors@'~0.6.2' but will load
    npm WARN unmet dependency /home/mboisvert/Documents/nodemongo/node_modules/colors,
    npm WARN unmet dependency which is version 1.1.2
    npm WARN unmet dependency /home/mboisvert/Documents/nodemongo/node_modules/grunt requires rimraf@'~2.2.8' but will load
    npm WARN unmet dependency /home/mboisvert/Documents/nodemongo/node_modules/rimraf,
    npm WARN unmet dependency which is version 2.4.3
    npm WARN unmet dependency /home/mboisvert/Documents/nodemongo/node_modules/grunt-legacy-util requires async@'~0.1.22' but will load
    npm WARN unmet dependency /home/mboisvert/Documents/nodemongo/node_modules/async,
    npm WARN unmet dependency which is version 1.4.2
    npm WARN unmet dependency /home/mboisvert/Documents/nodemongo/node_modules/argparse requires underscore@'~1.7.0' but will load
    npm WARN unmet dependency /home/mboisvert/Documents/nodemongo/node_modules/underscore,
    npm WARN unmet dependency which is version 1.8.3
    npm WARN unmet dependency /home/mboisvert/Documents/nodemongo/node_modules/grunt-legacy-log requires colors@'~0.6.2' but will load
    npm WARN unmet dependency /home/mboisvert/Documents/nodemongo/node_modules/colors,
    npm WARN unmet dependency which is version 1.1.2
    npm WARN unmet dependency /home/mboisvert/Documents/nodemongo/node_modules/grunt-legacy-log-utils requires colors@'~0.6.2' but will load
    npm WARN unmet dependency /home/mboisvert/Documents/nodemongo/node_modules/colors,
    npm WARN unmet dependency which is version 1.1.2
    npm WARN unmet dependency /home/mboisvert/Documents/nodemongo/node_modules/grunt-contrib-watch requires async@'~0.2.9' but will load
    npm WARN unmet dependency /home/mboisvert/Documents/nodemongo/node_modules/async,
    npm WARN unmet dependency which is version 1.4.2
    npm WARN unmet dependency /home/mboisvert/Documents/nodemongo/node_modules/mocha requires mkdirp@'0.3.5' but will load
    npm WARN unmet dependency /home/mboisvert/Documents/nodemongo/node_modules/mkdirp,
    npm WARN unmet dependency which is version 0.5.1
    connect-mongo@0.8.2 node_modules/connect-mongo
    └── depd@1.1.0
    
    mongodb@2.0.48 node_modules/mongodb
    ├── es6-promise@2.1.1
    ├── readable-stream@1.0.31 (string_decoder@0.10.31, isarray@0.0.1, core-util-is@1.0.1)
    ├── kerberos@0.0.17 (nan@2.0.9)
    └── mongodb-core@1.2.21 (bson@0.4.19)
    /home/mboisvert/Documents/nodemongo/node_modules/mongodb/lib/mongo_client.js:437
                  throw err
                  ^
    
    TypeError: _.assign is not a function
        at new MongoStore (/home/mboisvert/Documents/nodemongo/node_modules/connect-mongo/lib/connect-mongo.js:114:19)
        at /home/mboisvert/Documents/nodemongo/src/database/mongo.js:111:27
        at /home/mboisvert/Documents/nodemongo/node_modules/mongodb/lib/mongo_client.js:434:15
        at doNTCallback0 (node.js:428:9)
        at process._tickCallback (node.js:357:13)
    

    Additional information:
    OS: Fedora 23
    NodeBB: 0.9.0 cee3918e9b8096e421933678178ddfe4e3b71adf
    Node: 5.0.0


  • For me this was fixed by installing Kerberos. e.g. on Ubuntu:

    sudo apt-get install libkrb5-dev
  • GNU/Linux Admin

    @vinjdw @Marc-Boisvert-Dupras Keep in mind Kerberos authentication is default off, so if the module does not compile, this does not stop MongoDB (or NodeBB) from functioning correctly.

Suggested Topics

| |