Mo time mo problems

Technical Support
  • Was playing around with nodebb today and loving it! Unfortunately, I decided to change the theme (to one of the other default included themes) and it nuked the forum. I don't know why, but it was no longer accessible. I tried running the restart command but it said there was no instance running. The start command didn't do much, either.

    So.....destroy droplet (am on DigitalOcean) and start again.

    Well, funny thing is I can't install nodebb this time around. I've been following the same steps to a tee. Even tried CentoOS, too. Regardless of the flavor of 'nix I try I always get this same error when running the setup:

    Error: Cannot find module 'mmmagic'

    I use the defaults during setup (see below for full details):

    **[root@forum nodebb]# ./nodebb setup
    19/10 04:03 [26348] - info: NodeBB Setup Triggered via Command Line

    Welcome to NodeBB!

    This looks like a new installation, so you'll have to answer a few questions about your environment before we can proceed.
    Press enter to accept the default setting (shown in brackets).
    URL used to access this NodeBB (http://localhost:4567)
    Please enter a NodeBB secret (feea4985-9f12-4f38-b284-be1c982a63a9)
    Which database to use (redis)

    19/10 04:03 [26348] - info: Now configuring redis database:
    Host IP or address of your Redis instance (
    Host port of your Redis instance (6379)
    Password of your Redis database
    Which database to use (0..n) (0)
    Configuration Saved OK
    [email protected] node_modules/redis

    [email protected] node_modules/connect-redis
    ā””ā”€ā”€ [email protected] ([email protected])
    Populating database with default configs, if not already set...

    throw err;
    Error: Cannot find module 'mmmagic'
    at Function.Module._resolveFilename (module.js:338:15)
    at Function.Module._load (module.js:280:25)
    at Module.require (module.js:364:17)
    at require (module.js:380:17)
    at Object.<anonymous> (/home/bmmcadmin/nodebb/src/file.js:7:12)
    at Module._compile (module.js:456:26)
    at Object.Module._extensions..js (module.js:474:10)
    at Module.load (module.js:356:32)
    at Function.Module._load (module.js:312:12)
    at Module.require (module.js:364:17)
    [root@forum nodebb]#

  • Which version of node are you using? I think there are issues with the most recent release and mmmagic

  • @BDHarrington7 No idea, and wouldn't know how to check it. Anyway, I already destroyed the Droplet so I can't answer that question. In a bit I will rebuild a new CentOS droplet and start from scratch.

    I think my biggest issue is simply not understanding file and directory paths. I am likely in the wrong folder running commands that expect me to be in another folder, etc.

    If I had hair on my head it would be gone by now.

Suggested Topics