nodebb_theme_vanilla out of date on fresh nodebb install



  • Greetings.

    I'm attempting to install nodeBB on a Webfaction node and is slowly making headway. I have never been a "web person" and the transition from typical LAMP based setup is a lot to take in, but the rewards look promising.

    Now to the problem:
    I installed nodeBB 0.7.0 via npm and slowly but surely gotten things to spin up. However, when I started nodeBB a lot of the plugins that came with the install seem to conflict with the forum. I followed the various tips and hints and ended up removing the lot. Now I'm stuck with nodebb-theme-vanilla not playing nice:

    25/9 12:11 [19625] - info: [themes] Using theme nodebb-theme-vanilla
    25/9 12:11 [19625] - verbose: [plugins] Initializing plugins system
    
    25/9 12:11 [19625] - warn: [plugins/nodebb-theme-vanilla] This plugin may not be compatible with your version of NodeBB. This may cause unintended behaviour or crashing.
    25/9 12:11 [19625] - warn: [plugins/nodebb-theme-vanilla] In the event of an unresponsive NodeBB caused by this plugin, run ./nodebb reset plugin="nodebb-theme-vanilla".
    
    25/9 12:11 [19625] - verbose: [plugins] Found 1 js file(s) for plugin nodebb-theme-vanilla
    25/9 12:11 [19625] - verbose: [plugins] Loaded plugin: nodebb-theme-vanilla
    25/9 12:11 [19625] - info: [plugins] Plugins OK
    

    nodebb-theme-vanilla:

    $ grep version node_modules/nodebb-theme-vanilla/package.json
    "version": "1.0.130",
    

    Any atempt to grab the latest release from github breaks horribly and nodeBB refuses to start. I take it that's due to the theme being developed for a more recent version of nodeBB.

    I have updated everything Node related by npm and 'nodebb upgrade'. I have noticed that I suddenly have a node_modules_0.6.x directory alongside the regular node_modules in nodebb/. No idea where that came from and I haven't touched it.

    Any pointers?



  • Why you want to use v0.7.x though?
    Is there any special plugin you want to use?

    Otherwise I would go for the stable v0.8.x branch.



  • Hey AOKP. 🙂

    No reason to use 0.7.0 other than that's what npm gave me. I thought that was the latest stable but if it isn't, I'll attempt a fresh install of 0.8.X.

    Thanks.


  • Admin

    @TiaZzz Knew I forgot something... v0.8.2 should be published to npm now (or soonish...)



  • Quick reply to let others know that v0.8.2 fixed my initial nodeBB woes. Thanks to AOKP and julian for the heads-up and fix.


Log in to reply
 


Looks like your connection to NodeBB was lost, please wait while we try to reconnect.