[nodebb-plugin-custom-pages] "You seem to have stumbled upon a page that does not exist."

NodeBB Plugins
  • It is a key plugin for me and the forum that i am building. It extends the possibilities of the software by a large margin. 😮

  • The custom-pages plugin should be compatible with v0.8.2... what's the problem?

  • I tried entering the routing as above, thank you for the correct routing format btw, but now i get a splash page for http.com. i had an error before but it appears that it was a dns error, due to the new result a day later.

    What is the format of the header, footer and content? HTML? its not been working. Any differences between what is expected by the program and traditional HTML?

  • anything working example to add to the boxes to make a valid page and i'll reverse engineer whats needed.

    Custom static pages are not loding. Whenever we try, it links to a "Not Found" page.


  • @lulzdevlol

  • The above suggestions doesn't seem to fix it. The main problem is that the template files actually gets deleted - though they reappear upon restart. I'm not able to figure out exactly what is causing it, since nothing gets parsed in the log files when it happens. (Except the error message stating that the lookup of view failed)

  • @atrius said:

    The above suggestions doesn't seem to fix it.

    Oh, yeah; indeed. You got the nasty one.

    22/9 03:01 [5842] - error:  Error: ENOENT, open '/home/atrius/nodebb/public/templates/teamspeak.tpl'
    22/9 03:01 [5842] - error: /teamspeak

    The error prevents NodeBB from starting up, ending in 3 restarts in 10 seconds, most likely an error on startup. Halting., correct?

  • @rbeer Nope, that line is not to be found within my logs and NodeBB starts up just fine.

    Full log output:

    26/9 11:57 [5974] - error:  Error: ENOENT, open '/home/atrius/pannekake-nodebb/public/templates/teamspeak.tpl'
    26/9 11:57 [5974] - error: /teamspeak
     Error: ENOENT, open '/home/atrius/pannekake-nodebb/public/templates/teamspeak.tpl'
    26/9 11:57 [5974] - error:  Error: Failed to lookup view "teamspeak" in views directory "/home/atrius/pannekake-nodebb/public/templates"
    at EventEmitter.render (/home/atrius/pannekake-nodebb/node_modules/express/lib/application.js:579:17)
    at ServerResponse.render (/home/atrius/pannekake-nodebb/node_modules/express/lib/response.js:961:7)
    at ServerResponse.res.render (/home/atrius/pannekake-nodebb/src/middleware/middleware.js:349:10)
    at renderCustomPage (/home/atrius/pannekake-nodebb/node_modules/nodebb-plugin-custom-pages/library.js:11:6)
    at Layer.handle [as handle_request] (/home/atrius/pannekake-nodebb/node_modules/express/lib/router/layer.js:95:5)
    at next (/home/atrius/pannekake-nodebb/node_modules/express/lib/router/route.js:131:13)
    at /home/atrius/pannekake-nodebb/src/middleware/middleware.js:195:5
    at /home/atrius/pannekake-nodebb/public/src/modules/translator.js:156:6
    at /home/atrius/pannekake-nodebb/public/src/modules/translator.js:177:4
    at Object.translator.load (/home/atrius/pannekake-nodebb/public/src/modules/translator.js:206:5)
  • That's odd.

    I actually can't reproduce your error. On 3 different setups, it's just working as long as you don't use / in the route field.

    Does running the forum with ./nodebb dev instead of start give more information? Because that's not a 'Full log'.

  • Sooooo, that worked. 🙂

    Removed the whack and it started working right away.

Suggested Topics