v0.7.2 crashes with newest persona


  • with the jump from persona 1.x to 2.0.3 it crashes the board/stops the board, not sure if anyone else is getting this. had to do a nodebb upgrade to go back to the previous

  • Plugin & Theme Dev

    @chrismccoy persona 1.0.21 is the last version that's compatible with NodeBB v0.7.2. Everything after that has changes for master branch, which is the development version.


  • ahh ok thanks for the clarification.


  • NodeBB's package.json has the entries:

        "nodebb-theme-persona": "^1.0.24",
        "nodebb-theme-vanilla": "^2.0.19",
    

    Both of these themes just updated their newest NPM version numbers to new major versions in the past 6 days.

    It's possible to manually npm uninstall nodebb-theme-persona then npm install nodebb-theme-persona@1.0.21 (notice the @1.0.21, explicitly requiring a version of the package to be installed)., but this is overridden and lost at the next npm install.

    I'm currently looking at NPM docs for package.json and NPM docs for semver -- caret ranges. Neither seems to address the problem where NPM automatically updates modules above the necessary required versions defined in the package.json in the nodebb directory.

    Can a NodeBB developer or someone well versed in NPM packages+versioning weigh in on this?


  • Update:
    My guess is this either has to be solved in the nodebb/package.json or in the npm configuration for the two theme modules.

    Here is what you get when you try to npm install with the included nodebb/package.json:

    npm ERR! notarget No compatible version found: nodebb-theme-vanilla@'>=2.0.19 <3.0.0'
    npm ERR! notarget ["0.0.1", ... ,"2.0.10","2.0.11","2.0.12","2.0.13","2.0.14","2.0.15","2.0.16","3.0.0","3.0.1"]
    

    and if I fix the nodebb-theme-persona version, I get this on the next npm install` right now:

    npm ERR! notarget No compatible version found: nodebb-theme-vanilla@'>=2.0.19 <3.0.0'
    npm ERR! notarget Valid install targets:
    npm ERR! notarget ["0.0.1",...,"2.0.1","2.0.2","2.0.3","2.0.4","2.0.5","2.0.6","2.0.7","2.0.8","2.0.9","2.0.10","2.0.11","2.0.12","2.0.13","2.0.14","2.0.15","2.0.16","3.0.0","3.0.1"]
    

    I was able to fix this by altering my nodebb/package.json from:

        "nodebb-theme-persona": "^1.0.24",
        "nodebb-theme-vanilla": "^2.0.19",
    

    to

        "nodebb-theme-persona": "^1.0.21",
        "nodebb-theme-vanilla": "^2.0.16",
    

    What is very strange:
    npm info nodebb-theme-persona:

      versions: 
    ...
         '1.0.14',
         '1.0.15',
         '1.0.16',
         '1.0.17',
         '1.0.18',
         '1.0.19',
         '1.0.20',
         '1.0.21',
         '2.0.0',
         '2.0.1',
         '2.0.2',
         '2.0.3' ],
    
      time: 
    ...
         '1.0.19': '2015-07-27T19:34:23.624Z',
         '1.0.20': '2015-07-28T13:34:58.458Z',
         '1.0.21': '2015-07-28T14:12:42.725Z',
         '1.0.22': '2015-07-29T16:42:57.039Z',
         '1.0.23': '2015-07-29T16:59:15.254Z',
         '1.0.24': '2015-07-29T19:21:23.722Z',
         '1.0.25': '2015-07-29T20:49:05.755Z',
         '1.0.26': '2015-07-30T19:25:36.378Z',
         '2.0.0': '2015-08-04T14:41:11.480Z',
         '2.0.1': '2015-08-04T14:50:34.904Z',
         '2.0.2': '2015-08-06T20:40:24.259Z',
         '2.0.3': '2015-08-07T04:36:23.502Z' },
    

    Notice the all show up under the time field of , but not under the versions field. I'm fairly sure this is why npm install doesn't find a suitable version of the npm modules / nodebb plugins to install.

    Output from npm info nodebb-theme-vanilla:

      versions: 
    ...
         '2.0.10',
         '2.0.11',
         '2.0.12',
         '2.0.13',
         '2.0.14',
         '2.0.15',
         '2.0.16',
         '3.0.0',
         '3.0.1' ],
    
      time: 
    ...
         '2.0.16': '2015-07-28T13:34:41.548Z',
         '2.0.17': '2015-07-29T15:31:44.952Z',
         '2.0.18': '2015-07-29T16:42:17.123Z',
         '2.0.19': '2015-07-29T16:58:55.254Z',
         '2.0.20': '2015-07-30T19:26:37.250Z',
         '3.0.0': '2015-08-04T14:32:22.192Z',
         '3.0.1': '2015-08-04T14:49:45.409Z' },
    

    Notice the npm install errors come from versions missing, but there are keys in the time dict.

Suggested Topics

| |