[nodebb-plugin-reputation-rules] Reputation Rules Plugin for NodeBB


  • No Ban for low reputation is bad I think BC it's unfair for new users. 😛

  • GNU/Linux

    v1.0.3 released
    Works with NodeBB 1.0.x and also 0.7, 0.8 and 0.9 versions as far as I know.

    Whats new:

    • Plugin configuration panel completely reworked, now looks more material, following the NodeBB ACP design style
    • New feature: downvotes can have weigh too. This means that downvotes can remove more than just "1" points to the one being downvoted, depending on the user reputation.
    • New feature: downvotes can now remove a custom number of points from the user who votes. It is called "downvote penalization". You can set this to zero to disable it.
    • New feature: you can set a maximum number of extra points for upvotes, cause "upvote weigh" is a percentage of user's reputation, and that can grow to very very high numbers, so now you can limit it.
    • New feature: downvotes can also be limited, same as previous point.

    Here is a screenshot of all the options you can configure from the ACP:
    alt text


  • Why this is not in ACP? Really need this plugin

  • GNU/Linux

    @Muchsin-Assegaf What is not in ACP?


  • @TheBronx your plugin.. Its the best 👍

    Owh, forgot to mention.. I'm using managed host by NodeBB.
    So I can't manually instal plugins.. Only plugins that already listed in ACP

  • GNU/Linux

    @Muchsin-Assegaf Thats probably because the plugin.json file states that the plugin can only be installed on v1.0.x:

    "nbbpm": {
        "compatibility": "^1.0.x"
    }
    

    And you are probably using an older version of NodeBB. I always use npm install so I haven't paid attention to this value to be honest. I can change it later and publish it to npm again so you can find it. What version of NodeBB are you using?


  • @TheBronx Now I'm using v1.1.0 and will update to v1.1.1 soon


  • @TheBronx Just to inform you that I'm using this plugin right now.. Its a great one, thank you

  • GNU/Linux

    @Muchsin-Assegaf said in [nodebb-plugin-reputation-rules] Reputation Rules Plugin for NodeBB:

    @TheBronx Just to inform you that I'm using this plugin right now.. Its a great one, thank you

    Glad to hear that 👍 Thank you too!

  • GNU/Linux

    v1.1.0 released

    • Now you can disable votes on messages that are "too old" (you can configure this in number of days, or 0 to disable)
    • Added nbbpm compatibility 1.0.x and 1.1.x (it should work in older versions, but I am not sure)
  • GNU/Linux

    Does anyone know if this plugin still works? Or if there is something similar? There is a note that says: "This plugin has no compatibility data, make sure it works before installing on your production environment." How can I "make sure it works" without installing it?


  • @zandertrek I tried this yesterday, and whilst it installed, I couldn't see anything in the ACP to configure it, so uninstalled it. I guess it's not fully compatible.

  • GNU/Linux

    @thebronx I would definitely be using this plugin if it were updated for compatibility. I realize this plugin and thread is aged so I won't hold my breath.


  • @zandertrek Yes, I'd use it also. Wonder if @TheBronx is still active here ? Since he hasn't posted since 2016 (in this thread), perhaps not. Maybe, we could ask @baris or @julian if they are perhaps willing to update it ?

  • GNU/Linux

    @zandertrek @phenomlab

    I haven't updated the plugin in a while. It's been a year since I spent some time on it, maybe this branch is more "compatible" but I found a bug while developing that feature and ran out of time so it was never merged: https://github.com/exo-do/nodebb-plugin-reputation-rules/pull/6

    Handling the logs, so that each vote is registered with the amount of reputation added/substracted to both the voter and the autor of the post, was quite complex. And then undoing votes. And then handling opposite votes (undo current vote and then handle the opposite vote). And testing it hehe.

    I can try again and see how it goes, hopefully plugins haven't changed too much since v1.13


  • @thebronx Awesome - thanks ! If it helps, the current version throws this in the log

    2021-09-09T15:50:00.663Z [4567/164128] - error: Error: Cannot find module './database'
    Require stack:
    - /home/sudonix/nodebb/src/plugins/index.js
    - /home/sudonix/nodebb/src/meta/configs.js
    - /home/sudonix/nodebb/src/meta/index.js
    - /home/sudonix/nodebb/src/start.js
    - /home/sudonix/nodebb/require-main.js
    - /home/sudonix/nodebb/app.js
        at Function.Module._resolveFilename (node:internal/modules/cjs/loader:933:15)
        at Function.Module._load (node:internal/modules/cjs/loader:778:27)
        at Module.require (node:internal/modules/cjs/loader:1005:19)
        at Object.<anonymous> (/home/sudonix/nodebb/node_modules/nodebb-plugin-reputation-rules/library.js:4:24)
        at Module._compile (node:internal/modules/cjs/loader:1101:14)
        at Object.Module._extensions..js (node:internal/modules/cjs/loader:1153:10)
        at Module.load (node:internal/modules/cjs/loader:981:32)
        at Function.Module._load (node:internal/modules/cjs/loader:822:12)
        at Module.require (node:internal/modules/cjs/loader:1005:19)
        at require (node:internal/modules/cjs/helpers:94:18)
    
    
  • GNU/Linux

    @phenomlab said in [nodebb-plugin-reputation-rules] Reputation Rules Plugin for NodeBB:

    @thebronx Awesome - thanks ! If it helps, the current version throws this in the log

    2021-09-09T15:50:00.663Z [4567/164128] - error: Error: Cannot find module './database'
    Require stack:
    - /home/sudonix/nodebb/src/plugins/index.js
    - /home/sudonix/nodebb/src/meta/configs.js
    - /home/sudonix/nodebb/src/meta/index.js
    - /home/sudonix/nodebb/src/start.js
    - /home/sudonix/nodebb/require-main.js
    - /home/sudonix/nodebb/app.js
        at Function.Module._resolveFilename (node:internal/modules/cjs/loader:933:15)
        at Function.Module._load (node:internal/modules/cjs/loader:778:27)
        at Module.require (node:internal/modules/cjs/loader:1005:19)
        at Object.<anonymous> (/home/sudonix/nodebb/node_modules/nodebb-plugin-reputation-rules/library.js:4:24)
        at Module._compile (node:internal/modules/cjs/loader:1101:14)
        at Object.Module._extensions..js (node:internal/modules/cjs/loader:1153:10)
        at Module.load (node:internal/modules/cjs/loader:981:32)
        at Function.Module._load (node:internal/modules/cjs/loader:822:12)
        at Module.require (node:internal/modules/cjs/loader:1005:19)
        at require (node:internal/modules/cjs/helpers:94:18)
    
    

    Yep, that was solved in that old PR.
    I have the plugin running in the latest version of NodeBB locally, not much has changed since last time.

    Gonna try and debug the thing with reversing votes cause I am not sure why it didn't work last time. If it works I can release a new version today.


  • @thebronx Fantastic - thanks

  • GNU/Linux

    v1.2.0 has been published
    Not much has changed:

    • Added compatibility with NodeBB v1.18.2
    • Fixed a bug where "Max upvote weight" and "Max downvote weight" were actually being used as a min, instead of a max 🙃
    • I've removed the "Reload" button from the settings panel as that is no longer required for the changes to apply

    I should probably remove the setting "Max downvotes per day" as that is now supported by NodeBB out of the box, or maybe try and change the main setting from the plugin instead of having two different values doing the same.
    But for now it will stay. You can just set it to zero in one place and the configure the other, not that big of a deal.

    Let me know if everything works.

    @zandertrek @phenomlab

  • GNU/Linux

    I am excited to try this out. At the moment I don't know how to install it. I see only the old version still. Please advise. Here is a screenshot of what I'm seeing.plugins screenshot.png

Suggested Topics

| |