nodebb web setup - Configure your database - Digital Ocean



  • Hoping for a little help here- I've tried to install nodebb 4 times now on a ubuntu droplet, get to the web installer each time, and each time I run it it just terminates and dies.

    I'm assuming It's gotta be either the "Host IP or address of your Redis instance"

    or the

    "Password of your Redis instance"

    That's blowing up in my face.

    So two clarifications:

    A) Is this IP the IP of my virtual server, or the local 127.0.0.1?
    I've tried both, though, and neither seems to work.

    B) Is there a default password if I do not set one?

    I hit install nodebb, and everything dies every time.

    Thanks for any help!



  • Its worth noting it gets to:

    Congratulations! Your NodeBB has been set-up.

    and then the Launch NodeBB thing spins forever.

    If you try to load

    <Droplet IP>:4567
    or
    <Droplet IP>:6379

    I get a

    This webpage is not available

    ERR_CONNECTION_REFUSED

    Error



  • ERR_CONNECTION_REFUSED

    This is a redis database error, you will need to look in config.json for your database configuration.

    Redis host is 127.0.0.1 on port 6379. If you've added a password in redis.conf within /etc/redis/ then you'll need to add it here too. If not, you can leave it blank, but that's not very secure. Database is usually set to 0, but this isn't really very important in the grand scheme of setting up a new forum.

    URL should be set to your servers IP Address:4567 (i think, mine is just the URL of the forum, then nginx handles the reverse proxy)

    I've not seen or used the web installer so I don't know how it works, I probably should test it to get some experience so I can try and support it. But via SSH, you should be able to do it with the following commands.

    Once you have the files in a folder.
    cd foldername
    npm install
    ./nodebb setup (here is where you specify an admin account etc)
    ./nodebb start

    Alternatively ./nodebb dev will give you a stack trace of everything that happens when nodebb starts, including any errors it encounters such as missing dependencies.


  • GNU/Linux Admin

    @testusertester said:

    Is there a default password if I do not set one?

    If you installed Redis via apt-get, there's no password 👼



  • Thanks for all the help!

    For anyone else with this issue, the end solution was setting up the server via SSH not using the web console, shutting down nodebb with ./nodebb stop

    running:

    sudo apt-add-repository ppa:chris-lea/redis-server

    sudo apt-get update

    sudo apt-get install redis-server

    to update redis, then starting nodebb back up using

    ./nodebb start


Log in to reply
 

Suggested Topics

  • 1
  • 2
  • 4
  • 13
  • 3
| |