Can't upgrade plugins



  • I'm running nodebb V0.7.0 and when I tried to upgrade nodebb-plugin-markdown plugin with ACP it says I should upgrade my nodebb version but I'm using the latest release.

    upload-1cfbe5f0-e638-489b-8bbb-88bedd85d6ba

    anyone experiencing this problem ?

    same thing with persona theme upgrade


  • GNU/Linux

    Hello @Charly86

    No worries! 🙂
    This is intended behaviour. The newest versions of the plugins include changes that were made due to changes in NodeBB core. You would have to update to v0.7.1-dev to be able to update the plugins.

    @administrators
    Second time (I've seen) this issue causing a post. Hiding -dev related plugin updates from -stable alltogether might prove to be wise.


  • GNU/Linux

    @rbeer said:

    Hello @Charly86

    No worries! 🙂
    This is intended behaviour. The newest versions of the plugins include changes that were made due to changes in NodeBB core. You would have to update to v0.7.1-dev to be able to update the plugins.

    @administrators
    Second time (I've seen) this issue causing a post. Hiding -dev related plugin updates from -stable alltogether might prove to be wise.

    You shouldn't be allowed to break the core release.


  • GNU/Linux

    @Codejet
    That's true.
    In the case of plugin-markdown and the mentioned themes (this issue also applies to theme-lavender and -vanilla), it is a different story though, since all of those plugins are considered core elements. They are also maintained by @julian and @psychobunny. I assume they know what they are doing. 😅



  • Got it thanks guys,

    Another way could be also saying what minimal version is needed in the alert message box. Such as something like : you need to upgrade at least 0.7.1-dev, this will make more clear for newbies like me 😉


  • GNU/Linux

    @Charly86 said:

    Got it thanks guys,

    Another way could be also saying what minimal version is needed in the alert message box. Such as something like : you need to upgrade at least 0.7.1-dev, this will make more clear for newbies like me 😉

    even @psychobunny and @julian would probably agree the versioning system is a little confusing...


  • GNU/Linux

    @rbeer said:

    @Codejet
    That's true.
    In the case of plugin-markdown and the mentioned themes (this issue also applies to theme-lavender and -vanilla), it is a different story though, since all of those plugins are considered core elements. They are also maintained by @julian and @psychobunny. I assume they know what they are doing. 😅

    Quite a few times I've upgraded past a certain point some plugin and destroyed stuff, repairable with themes etc maybe an idea would be to make it clearer (seperate?) what stuff can be upgraded and what not. Seems its a case of clicking install and crossing your fingers 🙏


  • GNU/Linux

    @Codejet said:

    maybe an idea would be to make it clearer (seperate?) what stuff can be upgraded and what not. Seems its a case of clicking install and crossing your fingers 🙏

    That's what the message in the OP's picture is doing, isn't it?

    @julian
    While we're at it: How do I get that information into the package-API?

    {"package":"nodebb-plugin-expiring-uploads","version":"0.2.2","code":"match-found",
    "message":"The plugin author suggests that you install v0.2.2 for your copy of NodeBB v0.7.0"}
    

    It's the nbbpm in package.json, isn't it?
    Because if it was, @Codejet, would failing upgrades fall into the responsibility of the 3rd party maintainer.

    ~goes installing 0.7.0-stable...~ 😇


  • GNU/Linux

    @rbeer said:

    @Codejet said:

    maybe an idea would be to make it clearer (seperate?) what stuff can be upgraded and what not. Seems its a case of clicking install and crossing your fingers 🙏

    That's what the message in the OP's picture is doing, isn't it?

    @julian
    While we're at it: How do I get that information into the package-API?

    {"package":"nodebb-plugin-expiring-uploads","version":"0.2.2","code":"match-found",
    "message":"The plugin author suggests that you install v0.2.2 for your copy of NodeBB v0.7.0"}
    

    It's the nbbpm in package.json, isn't it?
    Because if it was, @Codejet, would failing upgrades fall into the responsibility of the 3rd party maintainer.

    ~goes installing 0.7.0-stable...~ 😇

    Yeah that message is common sense enough, although, I can't recall seeing that type of message before? I've had problems only with theme upgrades breaking my nodebb pretty sure 😴 But I teels ya, upgrading still a bit cross your fingers hope for the best.. If you knew which plugins did not break the core. you'd be ok with installing them .. say if nodebb-plugin-markdown was in a section called 'upgrading these will not effect your nodebb' 😉


  • GNU/Linux

    I know what you mean, definetly. I was thinking about that, too. Spliting the rather huge list of plugins into categories would be great. You know, like putting -vimeo, -youtube, -topic-badges, etc. into Visuals, then something for Added functionality, -composer, -widget-essentials into coreish, the mailer-plugins and sorts into Connectivity.


  • GNU/Linux

    @rbeer said:

    I know what you mean, definetly. I was thinking about that, too. Spliting the rather huge list of plugins into categories would be great. You know, like putting -vimeo, -youtube, -topic-badges, etc. into Visuals, then something for Added functionality, -composer, -widget-essentials into coreish, the mailer-plugins and sorts into Connectivity.

    Awesome idea. No doubt @psychobunny would come up with something even better for sections in the plugins area eventually


  • Staff

    Ensuring compatibility is quite a daunting task, especially since core itself does change often (less so than before, but occasionally still does).

    In the case of bundled modules, that is, those defined in package.json, if they are out-of-date or too far ahead, they will cause NodeBB to not function. Its behaviour is quite restrictive, although it is intentional!

    We're considerably less restrictive when it comes to third-party plugins, and all we read is the nbbpm.compatibility portion of package.json. Even then, we can't ensure that a dev will keep this section up to date, or even that there will be a section at all! So it is merely a suggestion, though I am open to changes.

    I am considering changing nbbpm itself so that if a nbbpm.compatibility section is not found, it will not be added to the plugin listing. Right now a great majority of plugins don't specify compatibility information at all...


 

Suggested Topics

| |