error uploading, code : 403 ??

Technical Support
  • I get a "error uploading, code : 403" when trying to upload a site logo in the ACP...
    Any clue what 403 is and how to fix it?


  • Anything else in the server logs? Are you on latest master?

  • Nothing in the logs that reflect the time stamp of the uplaod event, and I am on the lastest version, however I did notice something,
    when I tried to do the "./nodebb log" command, it failed, then I thought maybe it has something to do with PM2?

    And I was right, I stopped using "pm2 stop app" and loaded it back with ./nodebb start, and the logo uploaded.

    Thing is what does pm2 do to it to prevent it from uploaded the logo via the ACP?

    P.S. While typing this post, this very forum just notified me that this forum was just updated, does this mean I now have to go update mine?

  • Were you running latest master or 0.7.0? If you are on 0.7.0 you don't need to update.

    Not sure why running with pm2 is preventing you from uploading, my guess would be user permissions.

  • Not sure what user pm2 tends to run as, so a workaround would be to apply more liberal permissions to the public/uploads folder.

    $ cd /path/to/nodebb
    $ chmod -R o+rw public/uploads
  • Thanks for the help, but still no joy when running nodebb with pm2

    Edit: take that back all of a sudden its behaving !! 😂

Suggested Topics